Analog pin and I/O pins are not working. But Rx, Tx, 3.3 and 5V is glowing the led

Bolt module ui is easy to use and therefore I had included it in my B.E. project and worked on it accordingly but now I am facing one problem related to hardware.

My input-output pin and analogue pin is not working, but my Rx, TX, 3.3 & 5V supply is able to glow the led light.

My code is also right and module is successfully connecting to the internet. I can vary the pwm as well as I/O pin through the Bolt application.

My I/O pins code( code photo added at the end):-


PWM code:-(done as per Bolt online tutorials)

@ganeshnm2000 Please share the code you have used. Did you write the code on bolt platform and linked the product with the hardware? Or where you using Bolt APIs to control from custom app or site.

Drive link, contains the video of my Bolt module

Yes I uploaded the code successfully to my bolt module.


As per your first video, you have connected the resistor end to A0 pin of the Bolt WiFi module. The A0 pin can never be used as an output. It is strictly an analog input pin.

For PWM code, you have to connect the resistor to digital pin 0. I know it saw analogWrite in the code, but it actually means PWM write, which is a digital pin mode, not an analog pin mode.

As for the other code, of controlling the digital pin states, I could not see the pin connections. Could you draw the pin connections on a piece of paper, and share the same with us? You don’t have to draw it perfectly, as long as it is understandable.

Sir I used the analog code previously too, at that time it worked smoothly with A0 pin.
Only A0 pin is compatible for giving value between 0-255 there fore I used it for PWM
I am attaching tinkercad picture of my circuit.
Please find it and provide your useful inputs.

Bolt pic

Hi @ganeshnm2000,

The pwm code cannot work with the A0 pin. We have not designed it to work that way. In fact, calling the analog write api call with the A0 pin, should give you an invalid pin error. (This is only visible with the http request, not the Javascript function)

If it worked for you earlier, then there may be have been a bug in the system that we may have resolved, that allowed you to use analog write with the A0 pin.

Also, please understand only the 5 digital i/o pins are compatible with the analog write function.

Finally, while going through your schematic, I have realized that, you have not mentioned which of the led pins are the +ve pins and which are negative. Can you confirm that the +ve pin is connected to the resistor? A way to confirm this, is to disconnect the digital I/O pin and connect the 3.3v ping of the Bolt WiFi module to the end of the resistor where you had connected the digital IO pin. If the led glows, then the connections are proper.

Another possible issue is the value of the resistor used. As per your schematic, you have mentioned 440 (yellow, yellow, Brown) ohms. Can you confirm what color bands are present on the resistors on your board?

1 Like

Yes sir GPIO 0 pin not A0 pin, sorry sir but my GPIO pins are not working as I mentioned earlier.

I am adding my previous projects video too to get more information about the connection. There I used one resistor common for all the cathode to GND connection. Also I had attached one pdf to show all connections that you mentioned. ( Refer same drive link)

To confirm 440 ohm resistor.


Please confirm, have you tested the Analog write code with the GPIO 0 pin? If yes and it does not work, please take a video of the same, making sure to show the code, and the pin connections and share it with us.

Did you test your LED circuit using the method that I had mentioned in the earlier message? I am referring to the test where you replace the GPIO pin with the 3.3v pin?

Please do this test if you have not done so. IF the test fails it will reveal any issues with the circuit components and connections.

Thank you sir, problem got solved.