Bitcoin Project

Could not build cryptography error” Please help

it would be helpful if you posted an image of the error.

Need to see your code as well as what command do you enter that causes this error ?

sudo apt-get update
sudo pip3 install boltiot
sudo pip3 install pyOpenSSL ndg-httpsclient pyasnl # this line causes the error
sudo pip3 install ‘requests[security]’

its pyasn1 and not pyasnl

Yes I did change it to 1 but after that this error shows up

Try installing these individually and make sure each one installs without any error

sudo pip3 install pyOpenSSL
sudo pip3 install ndg-httpsclient
sudo pip3 install pyasn1

Hi @desayan9,

Type the below commands in orders

sudo apt-get update 
sudo apt-get install build-essential libssl-dev libffi-dev python3-dev 

And also run your python code and send me the screenshot of the error.

1 Like

Thank you @rahul.singh1 it worked. Thank you @swapnil.ravi10 too.

1 Like