Bolt IoT wifi module not connecting to the cloud

The bolt wifi module was connecting to the cloud smoothly until two days ago. The two days ago, instead of connecting it with a charger, I connected it to a battery with a UBEC (with output voltage of 5V and current 3A). Since, I haven’t been able to connect it to the cloud despite multiple tries and setting it up all over again, etc. Would it be possible that the module is hampered because of the high current? Is there any way to fix that?

I also had not connected the D+ and D- pins when I was powering it through the battery, so if that could have caused some issue? I have tried connecting it with a charger (micro-USB) since though and it still did not work.

Hi @aarushi.altbird,

I have invited @vinayak.joshi to help you out with this query. He will be replying to to you by today EOD.

Do let me know in case you need further assistance.

Hi @aarushi.altbird,

High current would not cause an issue to the Bolt, if the voltage was maintained.

Does the Bolt WiFi module power up?
As in describe the behavior of the Blue LED when you power up the device.

If the Blue LED is blinking slowly, so.ething must have happened to erase the WiFi configuration on the device. All you have to do, is go to the Android app, and do the procedure for adding the device again.

It does power up, slow blinking of the blue LED. It also blinks fast when the laptop detects the bolt wifi module’s hotspot. But it’s not connecting to the cloud (the green LED).
Tried doing the procedure for adding the device again already, it didn’t work. Tried it with a normal charger as well.
Could it be the D+ and D- pins? I looked at the open source circuit diagram on the website and in that it seems like those points are floating so it wouldn’t matter

Specifically, it stops working when we get to the verify wifi setup step.

Power on the device, disconnect and forget the network from your laptop. Then setup the module again. If the blue led is stable but green led is off, Make sure you have internet access.

1 Like


As mentioned by @Adith625,

Power up the device. Make sure to make your laptop forget the Bolt WiFi module’s hotspot, and then setup the device again with the android app.

For this, just open your android app. Make sure you are logged in, and then click on the add device button and follow the procedure.

Do a screen-recording of the process if you keep facing issues with the same.