Bolt library showing error

while using ‘sudo pip3 install boltiot’, it is showing “ImportError: cannot import name ‘sysconfig’ from ‘distutils’ (/usr/lib/python3.8/distutils/”. Please help to resolve the issue. Below is the image. I have used Digital Ocean along with Putty software. I have already done previous steps
sudo apt-get -y update
sudo apt install python3-pip
Also did trouble shooting as given in the course content. Still not working but.
Even when trying to check pip3 version, it is showing same error. I am unable to download BOLTIOT library and also python libraries and modules like numpy, pandas and others because of this.

Don’t worry.
The same thing happened with me at the time of installation.
It was showing import error several times but I waited for some time and it wasn’t there.
Just wait for sometime.

I tried that but it didnt work.
Thanks anyway.


It seems that python3-distutils is not installed. Please install it using the below commands.

sudo apt-get update
sudo apt install python3-distutils 
sudo apt-get update
sudo apt install python3-pip

Do let me know in case you need further assistance.