Boltiot libraray installation is failed

Hi,

I have tried installing the boltiot library from visual studio as i have python3 installed in my PC.
used this command: pip3 install boltiot
I was getting error while installing the package.
Screenshot attached.


I have checked whether boltiot package is installed or not in my PC using below commands
help(“modules”)

python3
from boltiot import Bolt

but the result shows no such file.
Please let me know the solution for this.

Thanks,
Padma

Hiiii @shyamala.majji
Please run following command on terminal for installing boltiot library.

    1. sudo apt-get -y update
    1. sudo apt install python3-pip
    1. sudo pip3 install boltiot
      Hope this information is useful for you :+1:

Thanks @chetan.kandarkar99.
But i am not using linux/unix or virtual machine.
I have installed python3 on my windows PC and installed other packages successfully with pip3 install <library_name> command.
But boltiot library is failing.
And i am using 64bit.

Hello @shyamala.majji
It is require Digital osean or Virtural machine for that.
Hope this information is useful for you :+1:

There was an issue with DigitalOcean, so i am not using that. Boltiot support team suggested Repl.it.
But i am more comfortable with python3 which is installed in my PC as i was using visual studio IDE to write python programs. I am learning detailed python from another site. Hence installed Python3+Visual Studio. So i want to configure Boltiot in my own PC.

Please do the needful.

@shyamala.majji
i have install library in anaconda navigator in windows o.s ,by using pip install boltiot
try this .https://forum.boltiot.com/t/boltiot-python-library/10647/11?u=govindbagdiya22
go through this discussion hope it helps.

Thanks @chetan.kandarkar99 and @govindbagdiya22 for the solutions.
But I have just uninstalled Python3 and visual studio and installed again. Now boltiot library have been installed successfully.
boltiot with version 1.11.2

Thanks,
Padma

2 Likes

Do three steps before doing install pyhton library.

step 1-sudo apt-get -y update
step 2-sudo apt install python3-pip
step 3-sudo pip3 install boltiot

but If you are getting Python locale error: unsupported locale setting then run the following commands.

export LC_ALL=“en_US.UTF-8”
export LC_CTYPE=“en_US.UTF-8”
sudo dpkg-reconfigure locales

After typing the above command, a pop up will open. Select All locales and click enter.
And then another pop will open. Select en_US.UTF-8 and then press enter.

then after that your error will be resolved.

You should go and connect to linux via Digital Ocean and or you can use virtual box.For your given problem you have to install anaconda navigator in windows os by using pip install bolt Iot.

Hi Ujjwalg887,
Thank you for your response.
But I figured it out and resolved the issue by re-installing the python 3 and visual studio. You can see my previous response.

Thanks again :slight_smile:

1 Like

Hi sdhruvil64,

I wanted to run the code in windows instead of VM or Linux. Anyhow I have resolved it on the same day. It worked as well. Thank you for your response :slight_smile:

1 Like