Both the leds are stable but unable to connect to bolt on phone as the wifi is not being listed on phone

i have tried to restart my microcontroller several times but still of no use. Both the lights are stable but no device has been added to my bolt. I also checked on bolt cloud to see if the device is connected- it says no device connected. I also tried to restart my microcontroller but of no use. I also tried uninstalling and installing the app but of no use.
Any help in this regard would be appreciated!

Try changing your wifi password or preferably disconnect the current wifi connection and try connecting your device to alternate wifi connection. This may sort out your problem

1 Like

i have tried changing the password and connecting but it isnt getting connected. Tried connecting to other wifi network as well, but isnt helping.

Can you send the snap of your module

https://drive.google.com/file/d/1EAL0pHL0zZUxgCNw_f1R5yOs9Ma6cnle/view?usp=sharing

https://drive.google.com/file/d/1ECTMsLobcoUdZ0Ew13k3MNRPJZmtajXy/view?usp=sharing

same happened with me…
so I left my bolt module connected for sometime and left it for sometime like an hour.
why don’t you try leaving you bolt module connected for sometime and then check it…
I hope it’ll work

1 Like

To troubleshoot,

  1. Turn off any wifi that the module was previously connected to.
  2. Turn on your Bolt module by connecting the USB. The green light should be off and blue light will blink slowly.
  3. Redo the process by visiting the app and connecting to the wifi BOLTXXXXX. password - bolt1234.
  4. From the interface click the wifi you want your bolt module to connect with. (Make sure it is not a 5GHz (5G) wifi network).

For step by step reference - https://docs.boltiot.com/docs/setting-up-the-bolt-wifi-module

1 Like

still doesnt help :frowning:

Did you try to redo the bolt setup process?

i did try but did not help

Have you followed the exact step given on - https://info.boltiot.com/how-to-setup-bolt ?

What is the status of your module? Was the blue ligh blinking slowly when you turned off the wifi it was connected to earlier?

hi, Akshayan,

When I plug it into the USB, initially for a second or two only blue light is blinking slowly and after some time both green and blue are in stable condition. I have turned it off the wifi that it was earlier connected to but no use. I have tried every possible way out as suggested. I am guessing there is some internal manufacturing defect or so.

Is the green light ON even when the wifi is OFF?

i switched off the wifi and changed the adapter and tried all the steps from scratch. It has got connected in the devices section but but the green light isnt blinking. Beside the device , it shows a red symbol. can you help me figure that out?

Okay. So, the greenlight turns OFF when the wifi is OFF right?
Green light indicates that the Bolt is connected to the cloud. I hope that part is clear.

I need more information - The wifi you’re trying to connect with, is that a 5G wifi connection?

greenlight turns off even when the wifi is on. Its a normal 4g network

Okay. You have to redo the setup of Bolt, and make sure, the wifi password is correct this time.

There is a possibility, your module isn’t connecting to the wifi. But since it is visible in the devices section, you can use the API to reset your Bolt and redo the setup part.

Run this URL on your browser - https://cloud.boltiot.com/remote/API-KEY/restart?&deviceName=DEVICEID
You will see your API key and Device ID in your cloud.boltiot.com

API section -> XXXXXXXXXXXXXXXXXXXXXXXXXXX --> beside this there is a :eye: and Copy button

DEVICE section -> Device ID looks like BOLT6545673. yours could be any 6-7 digit number as well.

how do i use my API to reset my bolt. i tried doing the entire process from beginning but it still isnt getting connected to wifi and no light is blinking. IN the devices section, status is OFFLINE. I found the API FROM API SECTION and also got the device id, how to proceed to reset my bolt using this ?

In API section you’ll see API Request Builder> Click the dropdown menu under Select the operation you want to do> Choose Restart device > Click Build API request > Click Test API

value: device is offline, got response