Cannot install bolt library

Respected Sir/Ma’am

I am using VM Workstation and I am getting an error in the first command itself. I tried sudo rm command but it was trivial. I even tried the commands given for troubleshooting. The error is still occurring.

I am attaching a snapshot of the same.

Awaiting for your response.
Thanking You
Yours Sincerely
Binita Khua

Dear @binitakhua , make sure that you have installed a good vmware software , and you have to follow the steps same steps provided in the courses to install., and allow the permissions to install your ubantu and vmware, and also check your software of vmware supports windows or not.

I also faced the same problem while using VMware… I would suggest you to install VirtualBox. Virtual Box gives much better experience than VMware. Installations are much faster in Virtual Box.
Follow the procedure given in this link

I hope this helps!

  Hey this error occurs whenever a process when a command or application is updating the system or installing a new software, it locks the dpkg file (Debian package manager).

Refer this link to solve your issue:

Try running the commands below on a terminal.

sudo rm /var/lib/apt/lists/lock
sudo rm /var/cache/apt/archives/lock
sudo rm /var/lib/dpkg/lock
sudo dpkg --configure -a

To avoid such errors, just use a terminal to update your system instead of system GUI and do not try to force stop a system upgrade while it is running.