Cannot View This Device

I was working on an alarm system and can no longer view the device. I have looked at the documentation and other posts on this forum. I have tried reconnecting and connecting the internet, reconfiguring the existing product, creating a new product, and unlinking and linking device. It was working perfectly fine yesterday and it is online (there is no problem with the internet as I saw in a different post) but all of a sudden I cannot see the line graph. Please help!

Screenshot of what happens when I click ‘view this device’ under actions

Internet speed

Product page

Hi @kfernandez,

Could you share a screenshot of the code that you wrote for your device?

Also in the device view, right click on the page, and then select inspect. Take a screenshot of the console tab and share the same with us.

Sir, I got the same issue.

Here the screenshots of both console and the code that I wrote for the device.

For this project I got the output when I tried two days before which is only for the data in table view but when I now trying for data visualization its not working

Sir, I have gone through the error encountered in the page and found that the URL of the page is an HTTPS protocol and the page is requesting some source from another page which is a less secure version protocol HTTP. I think since the page is requesting a source from an insecure one than itself it’s encountering the error.
I think this can be resolved from the page administrator end like making the source page to HTTPS protocol.


You should be able to view the device view now.

Yeah sir, Issue resolved