Connection problem with boltwifi module

while connecting to WIFI module it is asking password and not connecting

hai @aryahimanshu996

Follow each step without skipping

  1. Go to playstore / IOS store and download the BOLT IOT application.
  2. Fill the required details. (email & password)
  3. Click on add device.(make sure you have powered your BOLT module)
  4. Click on the next step for a 2 to 3 of times.
  5. Click on Ready.(switch OFF the mobile data and switch ON the location service
    and click on the READY)
  6. If it is detected it will show the device ID.
  7. Click on continue ( Bolt module cannot detect 5 GHz based WiFi network change
    it to 2.4 GHz)
  8. After that select the WiFi network to which Bolt has to be connected. Click on the
    WiFi name to choose the WiFi network to connect give the required log in

If you are feeling difficulty to understand follow the below link

Hey @aryahimanshu996 ,
Check this steps -
1)You should have installed Bolt Iot app from playstore.
2)After creating an account ,you need to add your bolt device.
3)Then power ON your bolt wifi module,it will start its local wifi hotspot.
4)The wifi you are using should operate on 2.4 GHz.
5)Enter the correct password for WIFI and to verify click on the “eye” symbol the click on connect.
6)The bolt will restart and connect to provided WIFI .
7)The blue LED on ESP8266 chip will be stable.

Thank you.

1st:-When you power up the bolt wifi module, first it will show bule LED light. Which will be slowly blinking.
2nd:-Download the bolt app from playstore/app store.
3rd:- Login with your bolt cloud login ID. And click to add device. It will guide the behaviour of led’s (both blue and green)
4th:- it will show wifi name and password. Try to connect the bolt wifi from your cell phone (be sure that your own cellular(mobiledata) is turn off).
Once the bolt wifi is connected
It will show the available wifi network within bolt app.
5th:- connect the availabe wifi network thats showing.
(For ios device.)
Upto 4th step its all same.
5th:- type the available wifi name and respective password.
While connecting, the blue led will blink with higher rate compared to initial rate.
After connecting the wifi module will show stable green led. And blue led will be also stable.
Hence your wifi module is connected to internet with boltcloud.
Let me know if any error occure

as i had gone again with these steps but my mobile WIFI as well as other mobile WIFI’s are also not connecting

follow these steps properly
1)Install bolt iot app from playstore
2)fill registered email id and password
3)first power on the wifi module and and make sure blue light is on and click on add device on the bolt app.
4)you have click on ready and turn on location service
5)make sure you set wifi network to 2.4ghz
6)after that turn on mobile data from another device and make sure bolt is connected to it and give login details if it is connected green led blinks and if blue led is blinking fast it is emitting wifi signals
thank you

sir but it is still not connecting i had tried several time.
please help me

@aryahimanshu996 Can you try connecting to the WiFi hotspot manually using the password “bolt1234”?
Also which phone and android version are you using?

Sir as I also tried to connect it by this password but still it is not connecting and a I am using samsung m30s with android 10 .

1 Like

If it is showing to enter password or incorrect password then try the following steps:-
1.In your mobile Go to settings>
Connections>wifi>advance>switch to mobile data>Network exceptions>remove .
2.After this follow the steps as you have done before.
3.If its not working than try to connect for different networks of your family member’s by turning on the hotspot .

As according to your guidance I had implemented these steps also but still it is not connecting.


Can you record your screen while setting up the device and upload the video to google drive?
Share the link here so that we can investigate the issue.
sir this is the vedio

@vinayak.joshi @shoeb.ahmed1

Can you guys check this issue?

Waiting for the solution :frowning:


I am facing the same issue. My wifi module is not connecting to cloud. The blue led blinks fast but the Bolt app asks me to reconnect every time. I am using another mobile’s hotspot for internet. It operates on 2.4GHz as suggested. Most of the times, available internet connections don’t show up in Bolt app, and when sometimes it does, before entering password blue led goes back to slow blink mode. Please help!

Thanks in advance!



@aryahimanshu996: I looked into the backend and found that you device did come online on 2nd September. In which case you may be facing an extreme case of the issue shown in the below link

What you will need to do is everything mentioned in the earlier post, along with making sure that you phone is made to forget the Bolt WiFi before you try the setup again.

Hi @abhishek,

This could be the same issue, but I am not sure, as I don’t have your email id nor do I know what Bolt WiFi module you are using.

Please go to your Cloud dashboard, and check if the device is linked to you account. The create a product and link the device to the product. Ensure that the product has some sort of graph being plotted.

When you open the device view, you will be able to see when your device had come online last.

Hi @vinayak.joshi,

I have got my device linked to Bolt account. It was working fine day before yesterday and then somehow I am not able to connect since then. I was able to see LDR graph on bolt web platform.

My module’s ID is BOLT8025482. Please let me know if you get the issue rectified.
Let me know in case any further information is needed from my side.

Also, thanks for taking your time out and helping me.

Hi @abhishek,

Have you tried using a different mobile phone to configure the Bolt WiFi module?