Error while running telegram threshold temperature

i m getting this messge after running the program

What is the error you’re getting? Can you send a snap of that?

Check if there is any typing mistake in the bot_id. If everything looks perfect, and no typo errors are present, simply create a new bot. And use the new bot_id.

still same error is showing as earlier

Have you tried creating a new bot in telegram and put the new bot token?

yes
i have done it bt still same error

Share you conf.py file screenshot

Now, send an image of the bot token from the telegram botfather chat.
And telegram chat ID too.

Make another bot token. Even this token isn’t responsive. This happens to a few people at times. Try a unique bot name as well

restart your virtual box and run it maybe it will work this time

Hi @satishkumarcse1995,

From your BotFather Screenshot, it seems that there is OO ( CAPITAL O O ) instead of 00(zero zero). Please update your telegram_bolt_id variable.

Do let me know in case you further assistance.

and one more you have to make your BOT admin check that also

1 Like

earlier same code was running fine bt now it is showing this error

i have done it as mentioned in the module

@satishkumarcse1995
Have you used space/tabs to arrange the lines?

In python, you’re supposed to simply press ENTER at the end of a condition (after ’ : ') to avoid these errors. It’ll give the right amount of space (on the left hand side).

Only then, you’ll get rid of the indentation errors.

I have used space instead of tab. And also used equal space from left side and also maintained right margin bt still i am getting this error

That’s what. DON’T put spaces or tabs manually.

Follow this instruction.