FIRST IOT Project misleading values


#1

Dear sir,
I have changed the resistor values and all the trouble shooting steps in the first IoT project but still I am getting the values 1.02thousand and if I try to cover it with my finger,the values are raising to 68,70 and some times 300… please help me regarding this issue.Even though i have tried to change the intensity of light by using lams,torch lights,lamps etc…but still not able to get correct values.


#2

Try using a 330 ohm resistor instead of 1k ohm resistor.
The voltage generated at A0 is 3.3*R1/(R1+Rldr). In some cases Rldr value is lower than what was used in the video, this increases the voltage generated. Using a lower resistance worked for me.


#3

tried it but doesnt work :frowning_face:


#4

Did you try cleaning the resistor leads, they might be the ones causing an open circuit to form.
Can you check the resistance of your LDR with a DMM in both lighting conditions?


#5

For a solution of this problem I will suggest you to use another resistor of 10k in parallel with the previous one (10k)…It will lessen the equivalent resistance from 10k to 5k…Sometimes due to the internal resistance of the chip you may get constant values in different intensity so if you lessen the resistance it can fix the problem…I was facing the same problem and try this hack and got good result…Thank You…


#6

I also have faced through the same issue: In order to get a fairly sensitive light detection using LDR, it would be great to use a resistor having lower resistance values than 330k(ohm), as higher the resistance connected to LDR, we will need more less light(darkness) to get the average readings/values desired. ( Still the readings/values that you get from the sensor depends on the lighting in the room).

You may have a look at this video which may give you an estimate: https://www.youtube.com/watch?v=7a8svWMJzNg

If there is some correction to be done then please do correct me as I am also a beginner to electronics.


#7

Hi there,
Even i faced this problem .Try changing the resistor and you need to carefully update the value ,that is click on deploy configuration after you have covered the ldr or may be even use a torch.Once you have made changes you have to wait for atleast 10s then ,click on deploy configuration.


#8

Even i am geeting the same values as 1.02 thousand even after performing the above steps


#9

Instead of using 10k resistor, Use 330 value resistor. You will definitely get ample of different values each time. :blush:
Hope this helps. Thankyou @dasariaravindh21


#10

@dasariaravindh21 try changing the resistance value to 330(orange orange brown)ohm instead of using 10k ohm resistor this will solve your problem as I had the same problem and solved it by changing the resistance so try this.thank you.


#11

@Sowmyaseetha99 try changing the resistance value to 330(orange orange brown)ohm instead of using 10k ohm resistor this will solve your problem as I had the same problem and solved it by changing the resistance so try this.thank you.


#12

Hello…
once check that your wifi is working well and also click on deploy configuration and then on view option in your Bolt cloud so that your new data is updated. It will work with 10k ohm resistor and if u want u can change the resistor. 10k resistor worked for me.


#13

Hi i have tried both 10k and 330 but it doesn’t give value 1,and 0

i have attached the values that i received please help me


#14

can you please give me a screenshot how the values change while using 330 value resister