Home automation bulb not turning off


#1

Home automation bulb not turning off. There is one problem with device.... You may have seen comments on hackster.io home automation using bolt iot project.... Actually when we do that according to tutorial there bulb doesn't goes off because when we give ON signal the potential difference among GPIO pin and 5V pin is 3.5V and when we turn off the potential difference is 6V(approx) that's why it does not goes off. Its not only the problem with me, others or also facing the problem.... But now i did it with diodes. But please sort out the issue..... Till now I have sorted the same issue for 2 people with diodes


#2

Hi @palakaggarwal62

I have given the same reply on the hackster project. You can read it below if you want to.
https://www.hackster.io/boltmakers/home-automation-8cc388

Please check the markings on the relay module.

The issue you mentioned happens if you do the following connections.
5v pin of the relay connected to 5v pin of the Bolt.
GND pin of the relay connected to pin 4 of the Bolt.
The input pin of the relay connected to GND pin of the Bolt.

These connection issues happen because there are subtle differences in relay modules from different sources.

Please use the following connections to get the desired results.
5v pin of the relay connected to 5v of Bolt.
GND of the relay connected to GND of the Bolt.
The input of the relay connected to pin 4 of the Bolt.


#3

You are right @vinayak.joshi sir on your part... You mentioned right rules.

But the issue is with device. When we give high signal the potential difference between pin 4 and pin 5V is 3.5V

When signal is given off to turn off the bulb the bulb doesn’t goes off with the same code because than the potential difference in pin 4 and pin 5V rises instead of going down i.e. It goes to 6.5V and bulb doesn’t goes.

That’s the issue. So I am talking about sorting of this.

I did it by using two 4007 diodes in series with pin 4 and also reversing the signal.
To turn on set to low.
To turn off set to high.

But i need this to be sorted out with device. Its not only the issue with me. But others too. I have sorted this before for 2 people.

I want that device must be checked.


#4

Hi,
What you mentioned about the device, the correct values are as foows.

When pin 4 is set to high, the device set the potential difference between pin 4 and GND pin of the Bolt to 3.3v (± 0.1v) . When the pin 4 is set to low, the device sets the potential difference between pin 4 and GND to 0.

If you measure the potential difference between pin 4 and 5v pin, it will give the voltages that you mentioned.

The device is supposed to work that way, and if the connections are made as per what I mentioned in the earlier message, the system works fine. (This is based on the tests that we have done today in our lab).

I believe there is a discrepancy between the circuit that you are using and the circuit mentioned in the project, which is causing the issue where you cannot turn off the bulb.

Please help us understand what this discrepancy is.
To do this, it would be really helpful, if you draw the circuit that you used to ‘fix’ the issue that you found in the system.

Also please help me understand, why you are measuring the voltage difference between pin 4 and 5v pin. I believe that this voltage is not significant to the circuit. I want to understand why you feel this voltage is significant.