How to copy, paste text in VMware?

I am unable to copy in my VMware terminal. Could anyone help me out regarding this issue?
Also, I have tried all the previous suggestions on the forum but they were of no help like, I tried updating VMware tools and did not find guest isolation, the shortcut keys are also not working and there is no right-click option, etc.
It’s really takes an effort to type in all the keys and ID’s. :cry:

hey @aksharakaul ,

check out this link it might help

You can use putty software from where you can access your Ubuntu server.In Putty you can paste the content by right click
1)Install Putty from this link
2)Type command ip a in vmware to get the ip
3)Now using Ip address login to putty where you can paste the content

@aksharakaul, also see this link, it has worked for me

hey, @aksharakaul
I Think this might help you

You can send the text you want in what’s up to yourself and open what’s up in VMware and copy it and paste it by clicking ctrl+shift+v. It has worked for me
I hope it works for you

One solution which worked for me is copy the text in windows in normal way and to copy in the terminal use shift+insert to paste the text u have copied earlier

copy the text in the normal/usual way in windows then to paste use shift+insert on terminal

hello @aksharakaul,
you can open the bolt training website in the VMware directly through a browser and you can use copy paste then.

Hey @aksharakaul !

  1. Open VMware.
  2. In the window around Ubuntu, click Settings>Devices>Shared Clipboard>Bidirectional
  3. Open a terminal and type nano
  4. Type testing 1,2,3 into the editor
  5. Select Testing 1,2,3 with your mouse , right click Copy
  6. Open notepad, right click and select Paste
  7. In notepad type 4,5,6
  8. Select 4,5,6 with your mouse, right click and select Copy
  9. Back in nano, right click in editor and select Paste
  10. Type Ctrl+X then type ‘n’ to exit nano
    Hope this helps!
1 Like

Thank you @uietcse1822monikayad for your solution!

1 Like

Thank you @durgarani9866 @gpatil180601 @ujgopalakrishna @saibharadwaj040 @chinni.deeptimeela @daksheshch for your help!

Hey, @aksharakaul I have one solution.
Copy the text from windows OS.
Open the terminal( VMWare) press the left click to paste it works for me. An alternate solution, try to install the ubuntu-desktop version for GUI. Here you can open a browser and copy the content and paste it into the terminal. It is similar to window desktop easy to use for beginners.

You were not able to use the windows shortcut key’s in Linux.
Hope this helps you.

Hey, @aksharakaul
Since windows schortcut keys don’t work in ubuntu. Here’s what you can consider
Try getting the GUI(Graphical User Interface) version of ubuntu for your PC, which makes life much easier rather than using CLI version
Paste all the data you need into a note pad and open the note pad in VM Ware and copy paste it using
ctrl+shift+c and ctrl+shift+v
Hope this works.

hey @aksharakaul , related to your problem, i suggest to Go into VM / Settings / Options / Guest Isolation. UNCHECK bothcheckboxes (Enable drag and drop, Enable copy and paste) and click OK. Shut down the guest, and shut down VMware Workstation. Reboot the host computer.