Http error, temperature sms

There was an HTTP error along with unable to create record

while executing the code for Project 9( Sending an SMS when Temperature Crosses Threshold). I corrected the temperature threshold message trigger(i didn’t know spacing mattered earlier), but now i have a problem in sending the message( related to Twilio i guess). There is a screenshot of the error in the screenshot.

@laicosnetcom It seems that your Twilio configuration in the conf file is incorrect. Most commonly, it may be a spelling mistake like 0/O or 1/I etc.
Please check if you have used the correct credentials.

I also have the same error like @laicosnetcom

And here is the code:

please help with this :pleading_face: :pleading_face: :pleading_face:

cross check your twillo credentials and also make sure you have provided same and all details mentioned in the training page.

There may be a problem in the section you can check the APIs inserted correctly or not.

can u help me with the steps to correct it…

can u send me the screenshots

Looks like there is a problem with from no in the file. The from no copied from twilio dashboard is only the first 11digits before any other characters.

Check your twilio dashboard and verify if you have typed the exact credentials in the . After you verify and execute the code and if the problem still exist , then i will check if there is any other prob

Your coding should be correct. That error comes in your wrong details provided in your file.

import conf from boltiot import Sms, Bolt import json, time minimum_limit = 300 maximum_limit = 600 mybolt = Bolt(conf.API_KEY, conf.DEVICE_ID) sms = Sms(conf.SID, conf.AUTH_TOKEN, conf.TO_NUMBER, conf.FROM_NUMBER) while True: print (“Reading sensor value”) response = mybolt.analogRead(‘A0’) data = json.loads(response) print("Sensor value is: " + str(data[‘value’])) try: sensor_value = int(data[‘value’]) if sensor_value > maximum_limit or sensor_value < minimum_limit: print(“Making request to Twilio to send a SMS”) response = sms.send_sms("The Current temperature sensor value is " +str(sensor_value)) print("Response received from Twilio is: " + str(response)) print(“Status of SMS at Twilio is :” + str(response.status)) except Exception as e: print (“Error occured: Below are the details”) print (e) time.sleep(10)

The credential discriptions:
SID = ‘You can find SID in your Twilio Dashboard’
AUTH_TOKEN = ‘You can find on your Twilio Dashboard’
FROM_NUMBER = ‘This is the no. generated by Twilio. You can find this on your Twilio Dashboard’
TO_NUMBER = ‘This is your number. Make sure you are adding +91 in beginning’
API_KEY = ‘This is your Bolt Cloud accout API key’
DEVICE_ID = ‘This is the ID of your Bolt device’

I think there is a issue with Twilio dashboard
if there is another alternative dashboard plz suggest me

Try email instead of sms. (mailgun). The problem can be solved by just correcting your credentials.
If you want other services you can just google alternatives to twillio. There are many

I’m getting alert via email is perfect

then its sure its a problem with your twillo account.
if you did all the steps as such told in bolt training and if your credentials are spelling error free it will work sure. And if are finding it dfficult, i will send you a new account details and credentials.
whats your emailid?

email id =

Hi @RJRohit98 and @laicosnetcom

Check in your conf file. There must be some typo error in Twiio credentials. You can use this link to run your code online and also can directly copy paste code/credentials VMware, Virtualbox, Digital Ocean all are not working : Solved

Also I have mentioned one of the alternative of Twilio is Karix . Check the code snippet here Sms status : queued

Do let me know in case you need further assistance.

I have checked both the files in SID, AUTH_TOKEN, FROM_NUMBER, TO_NUMBER everything is correct and in code is correct but also getting the same error.
I think there is some issue with Twilio but I can’t find it.

Hi @RJRohit98,

Please send the screenshot of your conf file to . Also send the Twilio token copying it from Twilio dashboard. Have you tried the same on VMware, Virtualbox, Digital Ocean all are not working : Solved ?