I already accessed the training but it can't show any video on the page

i start my IoT and ML training today, but i faced so much difficulties today like

  • “Previous Lecture” button is not worked properly
  • “Complete and continue” button is not worked properly
  • even i complete some starting portion of training, it shows 0% complete
  • when i start my introduction portion it doesn’t show any video(it shows blank page) even if i refresh so many time.

please help. What should i do?


Hello, Apologies for the inconvenience. The website works perfectly fine on my side. Did you try to switch to a better connection, or any other browser?

You can also ower the quality of the video from the bottom-right corner to have a bufferless experience.

Let me know if you are still unable to access the videos properly.

even if i change the browser, i faced same kind of issue.
Also my internet connection is good and work perfectly.
I didn’t see any kind of video content and progression is remains 0%.


The progression bar is not something you need to be concerned with. You can simply click on the top right section ‘Complete and Continue’ to get the bar into effect as well.

Share a photo or video of the buffering/blank page when you try to access the videos. It works completely fine on my side. You can try the same on other devices and let me know.