I am not able to deploy configuration

I am not able to deploy configuration as it says no hardware found

The image isn’t visible. Very blurry.

But I suppose it says, NO HARDWARE CONFIGURATION. Right?

Check your hardware configuration, if you have saved it after entering variable names.

I did man I did but still it isn’t deploying

Paste an image of the configuration tab.


This is what comes even after configuration

Do the steps to configure, when it shows SAVED, take a snap. Then write the code, save and take a snap of SAVED, then close the configuration window.

Link the device - > Deploy Configuration

If configuration failed, send those snaps over here.

1 Like

Just reboot the device and flash once again… This should work as it did for me.
Also make sure that the code is complete and there are no logical errors or compilation errors.

check your LDR and resistor connection, if it is done properly or not. Reboot the cloud module. definitely, it will configure it. Let me know if this helped you.

Step 1: Check the connections on the BOLT IOT Device
Step 2: During the Configuration, try to save the hardware connection and see what error pops up, in my case it was “Variable Name should begin with lowercase letters” check if that is the issue
Step 3: Check whether the variable names are proper in the code
If everything checks out, then try resetting the Bolt Device or Relinking the Device to the Written project.

That’s because the product that you have created is not linked to your bolt wifi module . that’s the solution to your problem . Same thing happened to me and that really worked for me . thankyou.

It seems like your Bolt Module is not linked to cloud. Please link it The symbol will show green when linked.

Hey, even I had faced the same issue. This worked for me: While configuring the device, make sure to save both the hardware and code. If we just mark the configurations for hardware and go for the code without saving it, it doesn’t work and same goes with code too. So, save both of them and see if it works.