I ma getting this error saying- No Hardware configuration exists for this device type, i followed the exact steps and code of the course

I am trying to deploy my product but then it gives me this error. The code was working a few minutes back and i was able to control my buzzer, but suddenly it stpped working. When i deployed the code again, I got the same error. I even created a new product but still the same problem happened.

My code:

    <script type="text/javascript" src="https://cloud.boltiot.com/static/js/boltCommands.js"></script>
    <script type="text/javascript">setKey('{{ApiKey}}','{{Name}}');</script>
        <button onclick = "digitalWrite(0, 'HIGH'); ">ON</button>
        <button onclick= "digitalWrite(0, 'LOW'); ">OFF</button>

I follwed all th steps of the course. when i tried for the forst few times, it worked anfd then i showed this erre. i even assigned a name to the pin and changed the code accordingly but nothing would happed, THe error would get solved but it woudl not work.
Please help @vinayak.joshi , @PPV , @rahul.singh1 , - in really need to solvew this basic issue. i check the led and the buzzer, they were working well with batteries. PLease PLease Please help


Hi @jindaldhruva… click on configure product and check if youve assigned your variable to one of the digital pins…you may have deleted that cofiguration by mistake

@yashil2004, that problem is solved and the configuration is deplyed. But, the buzzer is not working when i press on the on button. Please help me out.

@jindaldhruva Can you open the browser console and check what is being shown there? Do post a screenshot here.

Hi,Check can you connect any pin of hardware to 0 or not,because you use digitalWrite statement…If all hardware connection is correct then please off and on bolt iot & and connect & try.If you connect the led to analog pin then it’s return to error …So please check you hardware connection & check you define correct pin no or not.
I think this is helpful to you.
Thank You.

The console log looked something like this:
I clicked on the link beside the error message and it led m to a page which said that i had been rate limited for 12 hours or something. So i tried after 2 hours, it worked. But can you tell me what is rate limited and why was I rate-limited. Also, the same message- no hardware configuration for this device ttype still comes whne i deploy the cnfiguration but it works well if i just view the device.

Hi @jindaldhruva,
Details regarding rate limiting have been mentioned in the link below.

Thanks to all @vinayak.joshi , @shoeb.ahmed , @ankitkumarmajhi18…u guys really helped me out!!

Hi… sorry for the late reply…you may have kept the frequency low which may cause it to be inaudible. Note you can adjust the frequency between 0 and 250. Hope this helps!!!

You can try again and with better internet connection for connecting hard ware module. And make sure blue light is on.

I am Facing problem in project 3 : it Says No Hardware Configuration exist for the device type.
can you please help me out ?
I have tried link below But it won’t help me to solve my problem.

Project 3: Controlling LED error

I ma getting this error saying- No Hardware configuration exists for this device type, i followed the exact steps and code of the course