Issues with python3-pip nstall


Any idea what to do ahead

This issue came for cmd
sudo apt install python3-pip

Hi Gaurav,

Can you please share the entire logs? The log messages are not clear.

Sorry for late response below attached image is full screenshot after running the cmd its asking y/n but if I put y say to add external disk and if put n it stops the process

Hey @ggaurav955

Naïve Approach :boom:


A lot of errors can be seen when your Linux machine is not up-to-date
So what I suggest you to do is to both update and upgrade the system.
This can be done by the below commands


  1. Firstly update the system
    sudo apt-get update

  2. Now, upgrade the system. You gotta wait for it to download and install. Type y when prompted
    sudo apt-get upgrade

  3. Finally, try to install pip
    sudo apt-get install python3-pip

Final Words

If this doesn’t work, please reply back quoting the error.
Happy coding :slightly_smiling_face:

1 Like

HI @AbhishekR

When I run second cmd is also give same issue of disk space what to do for that.

Have you tried giving [ y ] when it prompts for additional disk space?

  • If yes, share the screenshot of error which comes after giving [ y ]
  • If you get " media change: please insert the disc labeled " follow SOLUTION#1


Just remove the cdrom entry from the sources.list file. This can be done easily:

sudo sed -i '/cdrom/d' /etc/apt/sources.list

This should take care of the problem. The message is because somehow you still have the cdrom entry in your sources.list file, you can check the content of the file using:

grep -v '#' /etc/apt/sources.list

This will show you all the repositories you have activated.

*** click on the link for reference website

Hi @AbhishekR
Yea I get same error as you mentioned above will try your solution given.

Hi @AbhishekR
Thanks for your help it solved my problem.

Hi @AbhishekR

Below attaching image please if you could help me with this too…

The error is at end of screenshot

— Hey @ggaurav955

Possible Solution :boom:

In line#20, you have to make the corresponding change

res = my.digitalWrite('1', 'HOGH')
res = my.digitalWrite('1', 'HIGH')


As you can notice, you have misspelled the word 'HIGH', which might be the reason for the error "Invalid value for pin"

Hi @AbhishekR
Yea will check that too but I still think that reading of pin A0 is not working.

I worked according to solution but its not reading value I guess or some other issue but not getting it

I faced the same issue while installing python in the linux machine provisioned with the digital ocean cloud. The available storage from the provisioned storage is less than the required, provisioning more storage and attach it to the droplet should solve the problem.

This may lead to some additional billing, please note.


Hi @ggaurav955,

I think you are rate limited by Bolt Cloud API because your time.sleep() function is outside the while loop. You have to write the time.sleep() inside the while loop.

For example:

while True:
   // your code

Do let me know in case you need further assistance.