LDR Project Values Error

I have made connections given accordingly as shown in the text. I have even tried the troubleshooting process but still, I am getting the same value(1 thousand) every time. I have even kept the bolt device in the dark still I am getting the same value.

1 Like

These may be the reasons, you are getting 1000 value. Try implementing these mentioned remedies.

  1. Look at the time of update. It may be that you are looking at old value, and not the new one.

  2. Check the connections of the resistor to a0 pin and GND.

  3. Try covering the LDR with your finger, and clicking on push data while your finger is on the LDR.

You may have received an LDR with internal resistance which is different from the standard. Try using the following combinations in the given sequence
3.3v - LDR - a0 Pin - 10k - gnd
3.3v - LDR - a0 Pin - 330 - gnd.

hi rohankhera13

Check the connections of the LDR to a0 pin and 3.3v pin. make sure both the LDR and resistor are inserted properly. if that didn’t work out try the same using a breadboard


ensure that you have perfectly inserted the LDR into the pins… I have also got the same problem at the begining… later i have reoved them and inserted again perfectly… and it was resolved… so you can remove it and place it again perfectly… and check if it is the same

bro i had the same problem the simple solution is please use a other resistor this will work paka bcoz even for me it is the same

1]You might have bend the ldr towards any led’s[i.e; the blue or green ones which are on the bolt wifi module] which might have resulting in the static value as 1000.
2]the resistor pin and ldr’s pin might have contacted some where.
-> please make sure that you have inserted the ends correctly into the holes.

I had faced the same problem, how I resolved it was by understanding the point the “You may have received an LDR with internal resistance which is different from the standard. Try using the following combinations in the given sequence”. So, instead of this sequence “3.3v - LDR - a0 Pin - 10k - gnd”, you should try this “3.3v - LDR - a0 Pin - 330 - gnd”. So, just change the resistor to 330 ohms.

This worked for me so you could try the same…

Hello @rohankhera13,
Try using different combination of the resistors.
If you face the same issue for all of the resistors then try combinations of resistors in parallel.
Remember that our Aim is to decrease the current flowing through the LDR, which depends on the opposite(In parallel) resistor. On connecting them parallelly the resistance reduces and thus allowing more current through the resistance and less through the LDR.

I had faced the same issue and it was mainly because the LDR we have received can have different internal resistance. Due to which we need to take care of the resistor being connected to it serially to form a balanced voltage divider circuit.
Hence try connecting the LDR with both the resistors i.e 10 Kohms and 330ohms one at a time and deploy the configuration. Then click on VIEW THIS DEVICE button.
In either one of the cases you will definitely obtain the required results.

You can try another LDR or Just clean the surface of LDR

@rohankhera13 Hey. Just check whether your LDR is touching the board properly. Or Maybe you had wrongly connected the resistor. please check whether your you had put the Brown, Black, Orange, Gold color. Don’t place your finger directly on the LDR. It is very sensitive and may damage.
just place your palm near the LDR at a minimum of 5 cms distance. and then press “Push Data To Cloud”. you will see the results changing.

Dear @rohankhera13,
See as discussed above that the maximum rating is 1.02 thousand, so we can not surpass that mark.
Please ensure that the connection made by you is proper as I faced this problem too earlier and then I connected the circuit properly and achieved the result.
I hope that you will get the desirable output.