Led controller stopped working after sometime

My led controller is not working.
it worked fine for sometime.
And suddenly it didnt work.
my light monitoring project is working fine.
what could be the problem

Hii @ss.selvaraj555 since it worked for some time, there will be no issue in the coding part. May be the problem is with your hardware connections. recheck your circuit connection and try again. Try changing the resistor and LED because it may be possible that LED got damaged anyhow while operating.

If you have several power supplies then try a different power supplies ,then try a different power supply onto the same strip to see if this now works. if it does,then you have a faulty power supply and will need a new one and another solution is i think led is burn that reason led is not working

if it worked probably there might be some connection issues try connecting the system again.

Since it is a breadboard prototyping, there may be loose connection in it. there is a chances of damage of product if you gave a higher voltage.

I have solved the issue. Thank you everyone.
The reason was that I used the api key multiple times in one minute.
So my Api key was blocked for few hours.
It worked finally after that.

4 Likes

it happens :slight_smile: