LED CONTROLLER stopped working

under home automation project i tried to do LED controller using an LED ,330Ohm resistor and bolt wifi module at first ir worked fine but after sometime it stopped working i recheck codepart and hardware connections but iam not able to figure out whats the problem

@kondruabhay please do share the code and the output and also elaborate what is the problem now?

The code seems correct, what is the problem that you are facing now?

donno after i finished coding i saved it and checked its not working

one small doubt do we need to click on deploy configuration.

@kondruabhay if it is not working now. I request you to check the hardware connections because it might be due to the fact that the LED must have been burnt. Please re-check the hardware connections:

Do the hardware connections from the scratch, use the another LED this time. I hope that will work for you

No @kondruabhay as you are just sending output to the GPIO pins there is no need to set the Hardware configurations in the product tab

so just saving code
file is enough right!!

After writing the HTML code for the product, save it and make sure that you have linked that product with the BOLT WiFi module. Can you share the screenshot of the Products tab ?

i checked all hardware components still not working but make note of it that when i first tried to implement it worked fine but after some time (20 seconds) it stopped responding

Check your LED with any other battery source. To see, if its working.

Use this URL to check if your connections are working - https://cloud.boltiot.com/remote/API_KEY/digitalWrite?pin=0&state=HIGH&deviceName=DEVICE_ID

@kondruabhay possible reasons for this could be:

  1. The LED is burnt (try another one in place of it)
  2. Rename the name of the html file from LEDCONTROLLER to something short say test

so that means my Api key is wrong? it is automated right

You have to replace the API_KEy woth your personal API KEY and also the Devoce ID. You can find the Device ID and API key on your bolt cloud dashboard

but the entry should bes automated right?

@kondruabhay make sure that you have enabled the API KEY in this manner: