Led controlling

hello my led controller is not working I have done same as per instructed but still my led is not blinking , whereas light monitor project worked fine. my API is also enabled. but still i am facing the issue.

Hey!
Please check if the hardware connections are proper and try using the other LED provided if one isn’t working. Ensure your Bolt device is connected to a WiFi with stable internet connection.
The link below describes the hardware connection: https://trainings.boltiot.com/courses/429176/lectures/6647868
The link below has the steps for troubleshooting this project: https://trainings.boltiot.com/courses/429176/lectures/6647933

yes i haved tried changing led but still not working and moved to buzzer project it is also not working.

Well the fact that your light monitor project worked states that you are well aware of the short and long legs of an LED and where those needs to be connected(i.e. shorter on GND and longer with resistor to GPIO pins).

Assuming that the problem might be in your code. Check if the pin u have mentioned in digitalWrite() is same as the pin u have connected your LED to.

Also make sure ur device is linked to your product.

if still not working, send us some screenshots.

@girianisetty
After you type the code, check the hardware settings also. You will have to select the ‘0’ pin and give the same variable name as you have used in the code.

i have wrapped resistor to positive of led

no i have not selected any such things
ok let me do it and one thing where should i use the variable

You need not change anything in the code. Use the same code as given in the tutorial and change the hardware settings. Your project should work fine.

no bro it didn’t worked

After typing the code and mentioning the hardware pin, save the changes. Ensure that the product is connected to your device. Click on the view icon on your devices page. A web page with ON and OF buttons should open for you to control the LED.
image

Hey! @girianisetty there is no need of selecting the pin in hardware in this project. I faced the similar problem with my buzzer that you are facing here but I got it done. If you follow the steps below you may get it too-(this is what I did)

Step-1-- unlink your device and delete the current product u created.
Step-2-- Poweroff your bolt device and turn it on, connect it again to your cloud…(but dont link it to any product yet)

Step-3-- make the necessary connections in your device as required (LED, resistor etc).
Step-4–create your new product and NOW link your device to it.
Step-5–Write your code in the code section(be sure about the pins in the code).and try not using additional styles(bootstrap etc) for now…nothing required in hardware section.

Step-6–SAVE IT. YOU MAY RUN IT NOW it should work.

ya web page is wroking well but on clicking on and off nothing works

yeah I am familiar with what you are trying to convey…GO on do as I said…It should probably work

ya let me try it . if i face any problem i will message again

yeah sure we are in it together

bro it didn’t worked

@girianisetty
I faced issues while doing this project too, and it didn’t work for me until I selected the hardware pin. I feel it is essential to specify the pin.