Led controlling

okay when you created the product and went on to configure it. Did u find the code pre-written there? in white color

@girianisetty because I tried doing that project again and encountered the same issue. what i did was
1Created a new product
2went on to configure it.
3selected the extension as html and the went back to LED control project.
4COPIED THE CODE from there and OVERWROTE it. with changes in the pin and functions.
Then linked my device to it after making my connections.
And it workedā€¦

I think maybe the order is crucial in which we proceedā€¦And the exact order is narrated in the project itself.

@spriyam095 @suvarnas I have fix it their was a API blocked i have resolved it on that day itself but my was not able to reply because the site was show up to reply after next 23 hours. but THANK you guys for you help and support

1 Like

@girianisetty That is good to know broā€¦Keep up

Try reconnecting everthingā€¦instead of connecting led directly to bolt module use bread board for connectionsā€¦use jumper wires for connectionā€¦and check the configuration settingsā€¦hope this will help you

Hello @girianisetty, I am facing the same problem as you did. Can you please guide me through it? I have also tried generating API Key and tried unlinking and then again linking, along with dismantling the complete hardware and then again connecting it, but still after clicking ON the LED didnā€™t turn ON.
@spriyam095 @suvarnas

@dhandehk98 check your mail whether you have received and API block mail.
if you have mail that your api key is blocked then unblock it as per the given instruction.

this will slove ur problem.

Thank you Guys @spriyam095 @girianisetty @shraddha.phuge17 @suvarnas , for the help.
My project started working. I will share the experience with you guys as well. I had done the connections as told in the course and write the exact same program as well, also, I turned ON the API Key and other steps told in the course. But even then I was not able to lid the LED after clicking ON on ā€œView this deviceā€. I tried to connect the LED and Resistor again and again but still failed.
But later on I checked my Bolt app on Mobile Phone it showed me the same options ON and OFF and then clicked on ON and the LED glowed, and later on worked fine as expected. After that I tried using option on website, ā€œView this deviceā€ to glow the LED and it worked fine via computer as well.

I do not know what the issue was I kept the same product in Product Tab but only reconnected the LED and tried and finally it worked.

1 Like

check which pin the led is connected and check whether you have passed the same value in digitalwrite() function as first parameter

@dhandehk98 yaeh bro I see that ā€¦Its great that you got it done.

@girianisetty Iā€™m glad the project worked!

@dhandehk98 I am glad the project worked!

hey! this is Mrunali,i started working on led controlling project after following the instructions i was able to make it to success but when i moved my pin to other pins and changed the pin no. accordingly in code my led was not glowing as per the command and if i again make it to pin0 my code works and shows me result. help!! how can i make it to other pins too?

Hi @mrunali.rajigare25,

Can you share the screenshot of your code and image of your hardware connection?

Also, check this link https://docs.boltiot.com/docs/write-digital-output-1 . Replace your device id, API key, and pin and enter the same URL in your browser and check if you are able to control the led.

Do let me know in case you need any other information.

hi @rahul.singh1
here is my screenshot of the code

my image of connection

hey @mrunali.rajigare25
Try making the connections on a breadboard. It worked for me. Here is an image of the connection

here is a screenshot of the code

the white jumper is connected to the gnd and the terminal of led corresponding to it is negative and the yellow jumper is connected to pin 3.