LM35 sensor value of 1024 is coming all time while performing the temperature monitor sensor project

My connection is perfect as i have tried with different bolt wifi module and it was giving proper temperature sensor values but with my bolt wifi module it always gives 1024 sensor value. Even if i use my friends hardware set up with mine bolt wifi module it shows the same error reading of 1024, i think my wifi module is not working properly as my hardware set up is giving proper result with my friends bolt wifi module but not with my wifi module.

please have a look and replace the product if possible

Hi @ankit07tiwari1992,

The screenshot you provided does not seem to match with the issue that you are talking about.

Where is the Bolt WiFi module displaying a sensor value of 1024?

If all other projects are working fine then the problem is not in the module but in the senor. Try with a new sensor with the correct connections as if you connect the sensor in a wrong way, there is a possibility that it will stop reading the correct values and will always show 1024. It generally happens when the ground wire is connected to the wrong pin or is not connected properly.

i have used same sensor with other bolt wifi module and then it was working that’s why sensor is working properly …there is problem with wifi module.

@vinayak.joshi have a look at this screen shot

Upload the screenshot of multiple output values of LM35.
Upload the code portion where you write the code.
and do change the LM35 sensor, easily available in market.

Hi @ankit07tiwari1992 ,

If you are getting output values as 1024 only via the LM35 sensor, check the wire connecting the sensor to the GND pin of the Bolt WiFi module.

This wire will most probably be loose.

@vinayak.joshi bro it is not loose or it would not be working with another bolt wifi module…and i checked all possible connection …problem is with my bolt wifi module …please tell me how to replace it . @PPV

Hi @ankit07tiwari1992,

If you truely believe that something is wrong with the Bolt WiFi module, please try the following experiment.

You have a 330ohm an a 10kohm resistor with you if I am right.

Disconnect everything from the Bolt WiFi module and try doing the following connections.

  1. Connect 1 end of the 330ohm resistor to the GND.
  2. Connect the 2nd end of the 330 ohm resistor to A0 pin, along with 1 end of the 10kOhm resistor.
  3. Connect the other end of the other end of the 10kOhm resistor to the 3.3v pin of the Bolt WiFi module.

Power up the Bolt WiFi module and confirm that it is connected to the Cloud.
Then run the following link via you web browser.

http://cloud.boltiot.com/remote//analogRead?pin=A0&deviceName=

Remember to add the API key of your account and the device id.

For example
http://cloud.boltiot.com/remote/2302e98a-9205-4edc-a1c1-e0844f39eed9/analogRead?pin=A0&deviceName=BOLT121212.

Take a screenshot of the response, and post it here.

Hi,
There is no problem with the value 1024, I also got the same value 1024. If you want to change the value cover the LDR with your hands. Some in the darkness also the value will not change, if this happens cover the LDR with your hands the value will definitely change.

  1. Try changing the resistor.
  2. Cover the sensor with your hand.
    Both the above worked for me.