My device(1st version) is not operating through cloud


#1

I have 1v unit of bolt it is already registered to the cloud but the problem is the device is not operating through bolt cloud.
And even my device has the data connection it is not showing ONLINE in the “cloud.botiot.com


#2

Hi @gowthamkrishnateja,

Is the device visible on the dashboard? If yes, then could you please elaborate what actually you were trying to do and not happening?


#3

I’m trying to control pins on the device but it is saying that the command timeout.

And in the dashboard also the device is not showing as offline though, the device has the net connection.


#4

I’m tagging on here because im facing the same issue.I’ll go through the problem and what ive tried

I have a bolt v1 (blue board). I wasn’t able to register it to the cloud and required support to register it for me.Now that thats done, I can see the bolt under my devices tab but it always shows as offline and product as NULL.

Regarding my device being offline. I am sure it is connected to the internet because i ran a code i had written a while back using the onboard bolt.js file( instead of the clouds boltcommands.js because it tries to use the cloud syntax by default) and jquery downloaded from a cdn and using jquery commands. The code works without any errors and downloads the jquery file without a problem.

About the product being null, I have tried writing a code on the cloud interface as well as uploading a html file directly from my computer. They both save as products, But when i try linking a product to a device, The popup which i assume is supposed to show me a list of devices is blank

And like @gowthamkrishnateja mentioned , when i try running a command from the cloud i get command timed out response

Also the API key has been enabled
so if anyone knows how to get around this, any help would be appreciated


#5

Hi @glennferns93 ,
Apology for the inconvenience. We are working on the bolt version -1 issue. It will be fixed by today evening.
I am also unlinking your device from your account. You need to link the device again with bolt_ip because Bolt IoT app is designed for Bolt version-2.

  1. Connect your Bolt to internet-enabled wifi network and find the bolt IP
  2. Type bolt_ip/register?email=glennferns93@gmail.com

Let me know in case you need further assitance.


#6

Thanks Rahul, That worked.