Not able to fetch boltiot package in ubuntu

I have written the code for temperature sensor project (with email service). The issue is whenever i run the code, there’s an Import Error: No module named boltiot
I have used sudo apt-get update and sudo apt-get upgrade respectively
and i am using Oracle VirtualBox

Please guide me through this

Thank You

Did you try installing the boltiot package from the terminal?

sudo pip3 install boltiot

Please check the response after running the above command.

Thanks a lot, i had to install pip also by command: sudo apt install python3-pip
and it worked

Even i have a problem with this, i used the above command: “sudo apt install python3-pip” but i am getting error like " unable to locate package can anyone help me with this?

You can try command: sudo apt install python-pip

I even tried using that, but still it is showing error
E: Unable to locate package python-pip

Try these commands.
sudo apt-get update
sudo apt-get install python3-pip
sudo pip install --upgrade pip3

I tried but getting error for the 2nd line itself.
It is showing “repository disabled by default” so I tried to enable main, universe, multiverse. But these were already enabled but still the problem exists

Look up “The manual way” in this link.