Not able to update packages via pip3

when I tried to install packages using pip3 command I get this error.

Use pip3 instead of pip.

@varunjkp2001 If you are using python 3 or a higher version like 3.8 then instead of using
sudo pip install boltiot
Try using sudo pip3 install boltiot
I hope it will solve your error.

I tried both pip and pip3 but I get the same error " Cannot import main"

Delete your ubuntu and reinstall it from the instructions and follow all the steps again

is there way of fixing the issue without reinstalling,and can anyone tell what was the cause of the “main” error

Hi,

Run the command below, and then repeat the steps of installation.

sudo pip3 install pip3 --upgrade

Upgrade pip3, this might work. Run the command below before installtion

sudo python3 -m pip uninstall pip && sudo apt install python3-pip --reinstall

it worked but iam still not able to update/download packages.I think it has to do with upgrading pip version.

Then it would be better to run the recommended command first and then continue with the process because the previous command worked for me properly. All the best.

i tried but it also does not work

How to get version 20.0.2?