Problem with the kit

Now I am in project 3: Controlling LED. My circuit connection is perfect and My Led is on when I click the ‘on’ button and it is off when I click the ‘off’ button. But when I did the project another time the led is not glowing. I checked the circuit connection, code and my API is also enabled. My bolt wifi module is working when I give the power supply. I am worried about the hardware kit. Is it working or not I don’t know. Please help me with this. I am sharing the first trail and second trail pictures of this project and the code.

make sure you led is in proper working condition!!

1 Like

hi, @yuvarajareddy001 as you says that you were using button interface ‘on’ & ‘off’ given in the default BOLT IoT module test page configuration and it was working then LED shouldn’t have any issue for glowing again.


Troubleshoot 1: If you think the LED caused some damage for this you can check it by connecting LED’s longer leg (anode) to 3v3 pin and other shorter leg (cathod) to GND pin of the BOLT IoT module without any coding. if it is still glowing then it’s in working condition and go for further troubleshooting mentioned below. otherwise LED might be damaged.
Troubleshoot 2: In case of LED project if you face same problem while LED was glowing in previous Troubleshoot 1 then you should check hardware configuration mounted on bread board as LED’s longer leg (anode) is connected to one end of register and other end of register is connected to a0 pin of the BOLT module. also LED’s shorter leg should be connected with GND pin of BOLT module. Else your coding is totally correct.
Troubleshoot 3: If everything was correct but still LED is not glowing then try with changing wires as well as bread board slots. now your problem should have to be solved.
1 Like

@yuvarajareddy001, I have a very good explanation for this issue as it happed with me as well but i figured the way out. This happens as you have exceeded the rate limit of api bandwidth provided to normal bolt cloud users like me and you. That is why, it is not glowing. The solution to it is:

  1. Right-click on the html page with you buttons.
  2. Click on inspect.
  3. Go to the console.
  4. There you would see an error named - "Failed to load resourse: the server responded with a status of 429(TOO MANY REQUESTS) "
  5. Just on the right of this error, there would be a like lokking something like this:
    image
  6. Click on it and it will take you to a page which will show for how much time have you been rate limited. If you refresh the page, the countdown updates.
  7. Do not do anything for that time period.
  8. Once that countdown is over, try closing the page and click on view the device again. This time your buttons would work.
    Here is the doc for rate limited incase you need it:
    https://docs.boltiot.com/docs/api-access-rules

I hope this issue was solved and you understtod the reason why it happened. PLease do let me know. Thanks!!

2 Likes

@jindaldhruva Thank You for the solution it is working now.

@akangirenb Thank You for the troubleshoot advice.

Glad it helped you!:smiley::smiley:

1 Like

@surajpandeydn Thank you for the reply, i got the solution from @jindaldhruva.