Project 3: Controlling LED error


i have connected LED as taught one leg of the resistor wrap it around the longer leg of the LED i.e positive leg. and negative leg of the LED into the ground pin of the Bolt and other leg of the resistor in digital pin 0 of the Bolt. and have checked my API and all that.

and wrote the exact code
still after pressing the “on” button the LED is not turning on.
Please assist.

1.I suggest you to once more make sure that the longer leg(+ve leg) is wrapped by the resistor and is connected to the 0 pin and the smaller leg is connected to the ground.
2.Please make sure that you have selected the output device and GPIO options while creating the product,if not it will not give output.
2.Then please enable API key is in the bolt cloud which can be found in the left side of the bolt cloud an if it is already enabled, then please click on Generate New API Key button and keep it enabled.
3.if these all are perfect, now don’t forget to deploy configuration (as you already saved the code in configuration of the product) and now click on the view device and try once more.
Hope it will help you!


here i have verifies all the circuit connection, then
also checked the product and regenerated API too but still nothing working!

are you sure the led is working? please check the LED with the Bolt app(to do this logout from the app and then login then a led checking feature appear with an ON and OFF button) or use an another LED.
Also try using a bread board for the connection.

I have tried with both the LED which comes with the kit,

i dont think using bread board will do something in this matter.

Replace your line 6 by:
script type=“text/javascript”

I have already wrote it in line number 5

You also closed the script tag in line no.5, in line no.6 it is a new script tag is declared so try including type attribute in it.

Everything seems fine here, try changing the pin from 0 to 1 and then try running the code. There could be a chance that your pin 0 might have an issue.

Check your code also.There might be some errors in cases of words.

@iamsajjadansari if you have done circuit connection right ,then you can tight the connections ,you can also generate new api key because there can be some issue with api key also.If you face some more issue let me know will help you further

Hi @iamsajjadansari
Check the wifi connection of the module is connected or not(the green light in module is on or not)
if the green light is on then check your hardware connections once again tight the connection and give it correctly and then go to the coding part and check it .

having problem…led not working …error is …no (No Hardware configuration exists for this device type)…pop up …as no guideline
in project 3 : :frowning:

@mohitmks619

As the error correctly suggests, you have not created/saved the hardware configuration for the product that you have created.

Please go back to the hardware tab and save the configurations as per your need. Do refer to the documentation/video of the course in case of any doubt.

Have you solved this problem , because I am also getting same problem. If solved tell me how?

Directly insert LED in Bolt GND and 0 pin (bypassing resistance) to check if your resistance has problem or not. Most of people will say not to bypass resistance, but this is just to troubleshoot, I myself did that and it worked without problem. Don’t worry LED will not burn but don’t pass current to it for long time.

it Says No Hardware Configuration exist for the device type.
can you please help me out ?
I have tried link below But it won’t help me to solve my problem, also insert LED in Bolt GND and 0 pin (bypassing resistance) to check if your resistance has problem or not As you say. but led is not turning on

Project 3: Controlling LED error

I ma getting this error saying- No Hardware configuration exists for this device type, i followed the exact steps and code of the course

I hope you have completed these steps. Linking product to device and deployed configuration.

I am also getting same error “No hardware configuration exists” only when my device is offline. If it is ‘online’ and connected to same wifi then this error doesn’t comes.

1 Like

@rajiv.sachdeva

Ya, naw I got the results thanks😊.