Regarding html tags on image tag

i wrote code for image to upload on website, when i opened the folder with browser my image is not visible on the website.

@vnarasimha.ipm Have you uploaded the images to a particular directory in your source code?
Usually, programmers upload all their static files to a specific folder like static and then use the path in their HTML code.
It would be better if you can send the HTML code that you have written. Please check if the file path is also correct.

The browser isn’t displaying the image maybe due to faulty code. The instructions, src is attribute of the image tab.
There could be syntax error, you could try putting the image in the same folder as your html docs

Just an example like if image name:src=“your pic.gif” instead of src=“yourpic.gif”
or Wrong extension: src=“yourpic.jpg” when your image is a gif… yourpic.gif.

You must specify the browser EXACTLY where to find the image.

A proper src is either a relative url or a full url that begins with http://

Hope it helps!!

2 Likes

Your image is not showing maybe because of the following reasons:

  1. The browser is unable to search your image so keep your image and html files in same folder.

2.Your image might be blocked by the browser , you can fix it by Clicking the Chrome menu icon in the upper right-hand corner of the browser. Click “Settings” on the left and then " Show advanced settings" at the bottom of the page. In the Images section, click “Show all images(recommended)”.

  1. Check that your image has a proper extension.

Use the HTML alt attribute to define an alternate text for an image, if it cannot be displayed.
Hope this helps.

1 Like

There could number of reasons this is happening -

  1. There could be a syntax error , so try checking the code once more.
  2. Try to save image in the same folder as your html file, this way it will be easier to track the pathway of the image.
  3. The name of the file could be wrong , even if a single letter is wrong or an upper case letter is typed in lower case. So to avoid this try copy pasting the name of image with proper extension.