Regarding project 6

Hi, I am facing issues when I open my file in python3. It throws errors and I am not able to identify those errors. Please help me to do so :slightly_smiling_face:

Can you be a little more elaborate? What kind of error are you getting? Can you share a screenshot or name the error?

Yes, I am sending a screenshot of the error

When I downloaded boltiot using pip3, it showed this

Please help me regarding this

What is the python version you are using? Because these errrors are faced by people using older python version. Upgrade your python version to 3.8 and try again

Hi @vijayolivefloor ,
Apologies for the delayed response. This error is faced in older versions of python like version 3.5. Kindly upgrade to Python 3.8 or higher. Check out this thread for more info on how to upgrade. Do let me know if you need any other help.

I am not able to upgrade to version 3.8,
when I try to create a virtual environment, it shows this

I tried to follow instructions of @ravi.ujjwal, but stuck there only


Follow these steps

sudo apt update
sudo apt install python3

Python 3 will be installed

If you are unable to solve the issue then we can connect over Zoom call and sort this out

I am able to download python 3, but the problem is I’m not able to download python 3.8, please help me to do so :slightly_smiling_face:

@ravi.ujjwal, please help me to install python 3.8 and sort this issue.

sudo apt install python3.8
this should work

I tried it several times, but it’s not working. I am unable to solve this issue. Please help.

@vijayolivefloor I have notified @ravi.ujjwal regarding this. He will help you out shortly.

Hi @vijayolivefloor ,

You can build the python 3.8 from the source -

1.Install the python3.8 code

  1. Unzip the folder
tar xfz Python-3.8.0.tgz
cd Python-3.8.0/

Run the make and make install

sudo make install

You can check the python3.8 is installed on your system -

/usr/local/lib/python3.8.0/bin/python -V

Then you can create a virtual environment using python3.8 path.

virtualenv --python=/usr/local/lib/python3.8.0/bin/python .myenv

Activate your new virtual environment -

source .myenv/pin/activate

Do let me know in case you need any other information.

I am getting this error, please help me to rectify

Hi @vinaygottimukkala200 ,

Check the error code - zlib not available

sudo apt-get install zlib1g-dev

After installing the above package, again do the

sudo make install

Do let me know in case you need any other information.

Please can you tell how to add a directory into a path?

Because it tells to add directory to path