Root ssh password


#1

iam following alternative option 1 for digital ocean and installed vm ware. i have got my ip address by using hostname -I and i clicked ssh root@“my_ip_address”, then it is prompting me to enter password. I entered my ubuntu password but it is showing that permission denied please try again for 3 three times. is there any password inbuilt ? or should i make any changes in the terminal


#2

I found the solution for the problem.
it was solved by the following commands.

  1. sudo nano /etc/ssh/sshd_config
    after that change PermitRootLogin to yes
  2. sudo service ssh restart

#3

@Nikhil What you have done is also correct, but there is an easier way to log in to your VM.

You only need to open VMWare/VirtualBox and press on the option to start the VM. It will open a display window and you can enter your user name and password when asked for it.
You do not have to SSH into the VM.