SMS and EMAIL with LDR

@akshayan.sinha , you know why @abutalahabelvadi was getting the error like Value not found I have an answer. It has nothing to do with the of importing the modules

Bro, the issue is solved.

Give me 05 minutes, I am drafting the correct answer

His json package was not imported, it only had read as a file in directory.

I have attached the link for your validation already.

@akshayan.sinha , brother when we give / process a number of API calls in a small amount of time then the Bolt service crashes as it can’t process all these requests in a small span of time. Therefore, the response which we get from the Bolt Cloud in the form of JSON has the following syntax:

{“success”: “0”, “message”: “A connection error occured”}

And if that time in the JSON object there is no value field so that is why @abutalahabelvadi why getting an error like KeyError: ‘value’. There is no link with the order of importing the libraries in this case.

Note: I am not saying this randomly, I created the same scenario and the result was as follows:

So the Bolt module resets automatically after a given time, so if you run the same code after a span of 30 minutes or even less then the code will run fine, because at that instant the API count would have been already reset and in that scenario the JSON object will have a value field that can be read by the program.

I am 1000% sure that when yesterday @abutalahabelvadi was trying to run the code, he must have run out of the API calls, so when he tried today the API counts will be reset and this the code ran perfectly

1 Like

@abutalahabelvadi , I hope I have answered your initial query of why the code was not running :slight_smile:

Brother, please look at his screenshot in the Query, the error is in line no. 15, where value was not found.

KeyError: 'value’

Key error refers to the key not found, similar to a dictionary of a list. In Json, values are stored in keys and values.

His whole package of JSON was not imported, that’s why couldn’t read in the program.

And it was already solved, as the person replied here.

You don’t have to focus on correcting, it is not a healthy behaviour when you don’t want to understand the error in a program and want to degrade others.

@akshayan.sinha , the query was not solved because of re-arranging the importing order. First of all thanks for letting me know that what KeyError refers to, so basically can you explain why in my case (the screenshot which I pasted recently), the value in the response was not there!!

Click Here

This is how bolt uses json here, its a randomized Bolt Device

Brother, I am just asking where was the Value in my json response. Please let me know!!

@abutalahabelvadi this is the final solution to the query. I request @rahul.singh1 , @yeshwant.naik and other officials to look into the same. :slight_smile:

I just answered About BOLT approaching Json.

Your json script was called. Because it was in correct order. You exhausted the no. of APIs every 1, 6 30, 60 mins thats why you could’nt place a connection.

https://docs.boltiot.com/docs/api-access-rules

Use cloud pro for better performance.

Great, you are saying the same thing I just wrote above. Brother the error in @abutalahabelvadi code wa not due to the wrong import procedure, it was due to the API calls.

Please go through this link

Brother, wait for 30 min only. I will clear your doubts

I don’t have a doubt. His error was solved after I asked him to correct the order and that’s it.

Please don’t make me report you. Be a good member of this community, dont spoil it, or my mood.

Brother I will be more than happy if officials look into the matter. We all must get to know whose reasoning was correct :slight_smile:

Wait for 30 minutes, I will draft an asnwer. Please do have a look in that :slight_smile:

@abutalahabelvadi, Please redo yesterday’s code and send a screenshot here.

Please do your work and studies than being a writer here.