Telegram error in execution

In telegram lesson when i try to execute the code, i am getting as boltiot module is not foundScreenshot%20(116)

1 Like

As you had mentioned above i came to know that there might be problem in the bolt library module .So,don’t get tensed it can be fixed by following some procedures to install it again…
As provided we need to do:

 Install python3 pip package.=>**sudo apt install python3-pip**
 Install bolt package library via pip=>**sudo pip3 install boltiot**
 Finally update the ubuntu if still this problem exists by using this **sudo apt-get -y update**

Do this! i hope it will work …So Happy Coding! If any further problem exists do post, let me check Thank U!

thanks for your guidance, same error was repeated.

once again check the spelling of the code such as capital letters may get varied in the package! for example: it maybe Boltiot or boltiot else bolt…


.i had tried many times but i am getting same error.

Hi @mohamedabdulkadher.1,

I think your Virtualbox is not able to get internet access inside the ubuntu box. To confirm the same, type the below command and send me the screenshot of the output.


Refer this link


It’s PING!@mohamedabdulkadher.1
Try it out…

Make sure you have an active internet connection…

Hi @mohamedabdulkadher.1

Sorry for typo, it is actually ping . I fixed in the earlier thread.


@arjunraj, @rahul.singh1Screenshot%20(122) . i tried the solution whatever you guys provide me but its not working…

@mohamedabdulkadher.1 This would only mean that your VM does not have internet access.

Hi @mohamedabdulkadher.1,

Check if this link resolve your internet issue

@rahul.singh1 solutions are not working its totally disappointing…

@mohamedabdulkadher.1 do you use any kind of antivirus? it could be possible to block your internet access to your VM if you have enabled thread level protection that would block the network access! so try to switch it off and give a try! or else try any other settings that would made disabled your access.
If not working try out other VM such as VM workstation and disable the metered connection option if any network connected is enabled as metered connection.

I had run the code provided here, check the interenet connection with vm and check all the spelling, indendation, conf file but still getting the same error