Temperature sensor is reading 100 degree celsius or 1024 sensor value

i can’t understand why it’s showing the room temperature as 100. Or i can say it’s reading it’s maximum value only.

@shantanusk.sk this is weird, the temperature can’t be that high … try changing the location of the circuit and see if you still get the same results, the code seems to be correct.
The problem must be with the LM35 sensor … or mostly its because of the location check the readings in a different room or place also try different code to check if the LM35 sensor is working properly.
i hope this helps do let me know if you find any issues.

1 Like

@abhishekkini80110 thank you, I tried that and got same output.

1 Like

Check the connections, Vcc to 5V , output to A0 pin, GND to GND.
I don’t think there’s any problem with the code. Try creating a product on bolt cloud and check if you’re getting the same output (similar to plant monitoring project). Leaving a snippet for reference.

Hope this helps.

1 Like

@nidhi.kunder32 thanks, i think it was loose/wrong connections, it’s working fine now.