The Bolt device is not powering up

Hi there,
Today i tried to power up my Bolt device,its not powering up i don’t know what happen to my device. I have tried other USB cables and also i even change the adapter.Still it does not power up today.Yesterday i was so happy that my device when connected to my home wifi network,today the device is not at all powering up. When i touch here

the device gets small amount of power(not enough to power up).After placing my finger there the wifi LED and cloud LED partially glow like this.I hope my fellow teammates will help me to solve this issue.

hoping a quick response from my fellow IoTians.

Try changing the USB cable.
or Power your device using a mobile charging adapter.

I have done it.But still no response

Try connecting it to an adapter and try to use new usb cable.
Do not connect the Bolt to a power supply greater than 5V and 1 Ampere

I have done it. After some time the device get powered on

@nidhin1996

I was calling you to discuss and know more about the issue that you are facing but was unanswered. Can you please call me back whenever you are free?

sure. I will call you back soon.

Hi Nidhin!
You can try doing the following

  1. Use a different port for powering up the Bolt device.
  2. Use a different USB cable.
  3. Check if your power supply if greater than 5V (because that might damage the device.)
  4. Check if the electrical components connected to the device are connected properly.
    I hope that works! Best Luck! :smiley:

Hi @sssorte1428!

You have seen the photo that i have attached with this issue. I have checked all the above you mentioned, still till the product does not work properly. I thinks it is regarding with the quality of the product. Hope the Bolt IoT solve my issue regarding the product.

Thank you for your solution!