Unable to add a product

I am unable to add a product on bolt cloud,I also clear my chrome browser catche files,I also read forum help instructions but they are unable to solve my issue.Please do someting on it. I follow same steps as on course video

@Prasad
1.Try to log out and login again for several times.
2.when you login, go to Add product and refresh the page once.
3.If you are using mobile to login. Then keep it in desktop mode and follow the above steps.
4.Make sure that you have connected the bolt device to cloud.

@Prasad

Are you getting any error message? Can you share a screenshot of the page after you create a product?

That Popup window DONE Button not worked although Popup closed button works thats my problem

as I build product clicked popup window shows there I click all info and check buttons properly but DONE button not worked and didnt add a product

You can try alternate browsers like firefox or try alternate internet connection, I am using Airtel Network sometimes i get this issues so I changed to another network and it works fine!!