Unable to connect Bolt Wi-Fi to my device at all

I tried connecting the Bolt Wi-Fi to my device through the Bolt IoT application. I followed every step: I connected the Bolt device to a power source. I also opened the Bolt app and switched on the Wi-Fi. I was not connected to any other Wi-Fi network. Initially, when my mobile scanned for networks, it found Bolt. I pasted the password, but my device would not connect with the Bolt hotspot. After a few tries, my mobile could not even see the Bolt Wi-Fi. How am I supposed to connect with the Bolt Wi-Fi if my mobile does not even show it? I have checked every solution regarding this problem on the forum and have been trying for the past 6 days. What should I do?

@adityaa.tc

What is the status of your Bolt Module? Green and Blue light are stable?

One more thing, when you try to enter the password of the WiFi on the Bolt App, does the App crash?

Do not panic. We are here for your support, we’ll make sure you are able to use the Bolt module by the end of the day.

No, the app does not crash when I enter the password (but it crashed today when I tried to open it). Blue light blinks, and even though I connected the device to a stable power source, the green light does not glow.

@adityaa.tc

Can you please try to setup the module from any other device with Android 11 and below?

We have conflicts with the Android 12 and our App.

If in case, it still does not connect, do let me know.