Unable to copy paste

i wanat to copy paste API key and some other long sequences in Vmware linux server my version of vm ware is latest 16.0

@kondruabhay Please go to Virtual Machine Settings. Click Options and select Guest Isolation. In the right pane, check the Enable copy and paste boxes. When you’re done, save your changes and Restart VMware and start the virtual machine. I Hope This tIme It Works

i dont have such setting

That’s an issue with Virtual Machines. You can refer to the below solution.


$ apt-get autoremove open-vm-tools
$ apt-get install open-vm-tools
$ apt --fix-broken install`

Close VM.

In Windows Host, in CMD:

echo off | clip

Start VM.

In case it doesn’t work. You can do your programming in Windows PowerShell as well.

for first command
for 2nd command
for 3rd command

Your first command is only wrong.

sudo apt-get autoremove open-vm-tools

you wrote open vm-tools

Anyways, I cannot give surity if the update will really fix your options settings.

You can use other virtual machine like Oracle VirtualBox.

But overall it is to run a python script in the linux environment. Which can be done in Windows as well.

well u diid mention open-vm-tools tho any ways
i did got same thing as before

oh how to do it in windows?

This will give you an essence of linux environment with black background.

But the easiest option for terminal interface, is to use Power Shell.

  1. Write your code in any text editor - Sublime or Notepad++. And save it with .py extension

  2. Then visit the folder where you filename.py is present (Your python file)

  3. Press Shift + RightClick with mouse.

  4. Click “Open Powershell Window here”

  5. Enter python3 filename.py

There are more ways to run python, there are IDEs like Pycharm, VS Code, Anaconda Navigator, etc

when i type python3 it opens microsoft store

i wrote my code and also mention configurtion in conf,py in sublime what should i do next?

Have you installed python3 from the given link first?

Which method do you wish to follow? CMD or Powershell?

Hi @kondruabhay,

There is no fix solution to enable copy-paste in vm. You have to google the issue and find out the solution. If you really want to copy paste your code then I will suggest you this thread How to Copy Paste in Ubuntu in Oracle Virtual Box from windows?

Do let me know in case you need any other information.

@kondruabhay is using VMWare. And in his Settings, the option, Guest Isolation isn’t present. Do see the matter, if that can be resolved.

well i wanna use CMD then

Go through the steps on installing python, till botiot package.

Then use the below method to run it smoothly from any folder.

It’s the safest option.

im getting like this