Unable to execute sudo pip3 install boltiot

I’m getting this error.

Please run the following commands in order:
sudo apt-get -y update
sudo apt install python3-pip
sudo pip3 install boltiot

Do let me know if you need any other help.

@raghav.srivastava still getting the same error.

Hi @dannypraneeth,
I have taken this to the team and we’ll get back to you shortly.

Hi @dannypraneeth ,

As I can see you are using Python3.5 and it has some issues with os library.

To upgrade to python3.8, use the below commands -

sudo add-apt-repository ppa:deadsnakes/ppa
sudo apt-get update
sudo apt-get install python3.8

Then install virtualenv package for python3.8

sudo apt-get install python3.8-venv python3.8-dev

Create a virtual environment and activate it.

python3.8 -m venv myenv
source /home/ubuntu/myenv/bin/activate

and then you can install the boltiot package using

pip install boltiot

Check this video How to install python3.8 virtual environment | create venv | activate venv on Ubuntu 20.04 - YouTube

Do let me know in case you need any other information.

1 Like

I am facing the same error like him and i followed your steps but when i type sudo apt-get update i am facing this

Screenshot 2022-06-07 142651
sudo apt-get install python3.8

Screenshot 2022-06-07 142713
sudo apt-get install python3.8-venv python3.8-dev

i am facing these @rahul.singh1

Still facing issue

Hi @dannypraneeth ,

Please follow this steps to fix cd rom issue Problem in setting bolt python library

I am also inviting @ravi.ujjwal to help you out over a remote session.

Kindly follow the below menstioned steps.
Steps to follow:

  1. Start Ubuntu.
  2. Type: wget https://www.python.org/ftp/python/2.7.9/Python-2.7.9.tgz
  3. Type: tar xfz Python-2.7.9.tgz
  4. cd Python-2.7.9/
  5. ./configure --prefix /usr/local/lib/python2.7.9
  6. make
  7. sudo make install
  8. /usr/local/lib/python2.7.9/bin/python -V
  9. sudo apt-get install virtualenv
  10. virtualenv --python=/usr/local/lib/python2.7.9/bin/python .Give_any_name
    Give virtual environment name of your wish
  11. source .Give_any_name/pin/activate
  12. pip uninstall pip
  13. curl "https://bootstrap.pypa.io/pip/2.7/get-pip.py" -o "get-pip.py"
  14. python get-pip.py

Now the bolt module can be installed properly.

If you are unable to solve I’ll arrange remote session to solve the issue.

1 Like

I was able to rectify the error, thankyou :+1:

hi there , after performing step 10 , I’m getting import error , i’m attaching the screenshot of what is shown on screen

Good morning @ravi.ujjwal sir
I am having issue in step 10
There is permission denied error

Please tell me What should I do


There will be space between python and .seven like this

virtualenv --python=/usr/xx/xxx/xxx/bin/python .seven

Good morning @ravi.ujjwal Sir now this error is occurred

please solve it as fast as possible I am stuck i want to make my projects also

zlib is module is not installed. For that you will have to run this command.

sudo apt-get install zlib1g-dev

Hloo @ravi.ujjwal sir
Again the same error is comming please help me

hi @Rohini , i was also getting the same error then @ravi.ujjwal replied me the following

" After installing zlib you will have to configure and make and make install step once again "
can you do it once and reply back if it works

@Rohini I have notified @ravi.ujjwal regarding this and he will help you out soon.