Unable to paste api key in ubuntu using virtual box

I am unable to paste the api key into the code while trying out project 6:Checking device status and restarting the device…I have tried out all options including using shift+ctrl+V and changing the settings of clipboard to bidirectional…i have been trying this since 4-5 days…please need urgent help to solve my query. Thankyou!

I also faced this problem. I can’t offer you a direct solution.
However, this is a workaround that i have used:

  1. Create a shared folder between the host and guest operating systems and enable its access.
  2. Next in ubuntu, enter this command sudo vmware-hgfsclient to get the list of shared folders.
  3. If you have enables shared folder access to the guest os, it should show up.
  4. Next, try to cd into the folder. It maybe mounted as either /mnt/hgfs/shared_folder_name or simply as /mnt/shared_folder_name
  5. Type out/copy the code into a file in the host os and paste the file in the shared folder you created in step 1.
  6. Use sudo cp /path/shared_folder_name/file_name destination_name_or_path to copy the file into your guest os.

Check this post How to Copy Paste in Ubuntu in Oracle Virtual Box from windows?


Thankyou so much! I tried creating the shared folder, but it did not show up when i entered vmware-hgfsclient …I followed all steps given by the link you shared…

Could you get it to work finally?

1 Like

Yes! Thankyou so much!

what did you do to get it work


Can you try this suggestion provided by @garain.ridyumna?

1 Like

okay!! thank you so much.

You could try typing it.
I hope it works.