Unable to start serial TX/RX communication


#1

My BOLT device is connected to cloud and I am able to access it using boltcloud url. So my device is connected well and working fine. I have my Arduino Uno writing to serial port and I would like to read that from BOLT.

As instructed in http://www.instructables.com/id/Interfacing-Bolt-With-Arduino-Bolt-UART/, I have tried to hit the http://192.168.1.7/serialBegin?baud=3 URL with no success. I have used Fing app to determine the IP address (192.168.1.7) of my BOLT device. I wouls like to set the baud rate to 9600 and hence used baud=3. I do not receive any response from the BOLT device after hitting the URL.

Is there any way to read serial data from BOLT cloud instead of local IP address?
I have tried cloud.boltiot.com/remote/api-key/serialBegin?baud=2&deviceName=device-name. The response for this with proper api-key and device-name is {“success”: “0”, “value”: “Invalid baud value”}

Neither local nor cloud URL seems to be working. Please help as it is very important for me at this time to get it working.


#2

Hi,

The API calls in the link you shared have been deprecated for quite some time now.

To read serial data sent to the Bolt via and Arduino please refer


#3

That worked. Thanks a lot!!


#4