Virtual Box Error

I am unable to open my VirtualBox getting an Vt-x error. I’m attaching the snapshot of my error.Screenshot

The reason that you are getting the error: VT-x is not available (verr_vmx_no_vmx)
is because the technology VT-x is disabled from your BIOS settings.
The steps of accessing the BIOS settings and checking if VT-x is enabled will differ depending on your motherboard manufacturer.

If its an intel processor and windows 10 then follow the below mentioned steps:

step 1. Go to settings
step 2. click on ‘Update and security’
step 3. click on ‘Recovery’
step 4. go to Advance startup
step 5. click ‘Restart now’
step 6. choose ‘Troubleshooting’
step 7. next, go to ‘UEFI firmware settings’
step 8. navigate to ‘Configurations’
step 9. Enable VT-x technology.

Finally, restart your PC and try to run VirtualBox.
This will fix your problem.

Thank You for the solution it worked for me !

This is the most common solution to such activation problems like these but however this cannot be applied to very laptop/PC having Windows 10.They may show up some different window as i faced so i have this solution:-
First, restart your computer. As the computer boots, press the corresponding key that lets you enter BIOS. The button differs from one PC to another. However, it’s usually F10 , Delete ,or the F2 key.

Once you enter the BIOS, you can start enabling virtualization settings. The BIOS interface varies depending on the brand.
use the arrow keys to choose the required actions.

You can follow these methods to fix the VT-x is not available error:

  • Disable the Hyper-V Virtualization

  • Enable the VT-X in BIOS Settings

  • Uninstall the 3rd Party Antivirus

  • Disable the Windows Defender’s Core Isolation