Bolt IoT hardware Wifi module not connecting to my smartphone

Both the Leds are on but Bolt IoT module’s wifi is not connecting to my smartphone. Please help


What is the status of the LEDs on the module when you give power to it?

Have you reached the setup process, where you need to choose the home wifi/ another hotspot(from a separate phone) and provide the credentials of it?

both the blue and green leds are on and yes I have reached to the stage where it ask us to connect our device ie smartphone to the Bolt IoT’s wifi

Hi @sahajsaxena11 ,
There is a detailed video in the lectures, in which sir explains in detail the way to connect the WIFI module, troubleshooting problems faced. I recommend to check them out.

But still from my end, the suggestion is that, you crosscheck the LED’s on the module.
Both the lights should be fully ON, not blinking. If the LED’s are blinking, then go though the tutorial once more.

Even then the problem persists, then check your hotspot connectivity again and repeat the process

Best wishes…

yes both the lights are fully ON and I have tried it many times no solutions yet


After connecting your device to the Bolt module, there are more steps, where you need to provide details of separate wifi, which the Bolt module will use to get the internet connection from. Usually, Home WiFis are used, but you can use a separate phone hotspot as well.

A detailed text tutorial is present on

Let me know if you have any other queries.


You can visit the Cloud Dashboard on to check if the device is visible on your account (same account as the mobile app).

I have followed every step showed but still not able to connect bolt ioT wifi to my smartphone



Can you elaborate on the issue? You can mention the steps you have followed while doing the process.

You can even shoot a video, upload it on drive and share the link in the thread.

I downloaded the app and logged in. After that I plugged the bolt wifi then it showed me the blue light
after that, it told me to connect to wifi and I did and showed a green light
then I clicked on continue and it says that bolt IoT is still not connected

@sakshum24 Hi,I too face this problem please repeat your connection it may help to solve or try to connect other wifi network.


You can share a video on the issue, that’d make things clearer.

We’ll see if there is anything missing from the steps you have followed.


Follow the mentioned instructions

plz see if u can check
sorry for the inconvenience


Looks like the device is already connected to a Bolt Account already. Hence the green light is ON.

To reset or check which email it is connected with, you can follow the below process.

  1. Turn OFF nearby WiFi connection (any wifi or hotspot nearby which you previously connected it with)
  2. Now, you should see the Bolt switching to Hotspot Mode. Where the blue light is blinking. (this happens when it gets disconnected from the connected wifi)
  3. Open the Bolt IoT App, and start with the setup process, you should see the Bolt Device there. Connect to the Bolt module’s hotspot.
  4. Turn ON the Home WiFi, and then refresh the wifi channels, and connect to the Home WiFi.
  5. If the Device was not connected to any account(previously), it should connect to the account and be visible in the dashboard as well.
  6. If it was connected to any previous account, you’ll see a pop up error message, with the email ID of the previous account.
  7. We’ll help you removing the device from the account post verification, and you can redo the process of connecting to your Bolt account again.

If you face any issues, do let me know.


By any chance are you using Android version 12? The latest android version is not supported by our app.

You can use any old version android phone to do the setup process. And you can update me over here if you still face the issue.

You won’t need the app once the device is connected to the Bolt Dashboard, you can continue your training from the Cloud Dashboard on directly

I am not using android 12 it’s the old version only
but I switched to another device and then tried connecting it worked

so thank you so much

1 Like