Bolt Iot Wifi Module setup not working

I followed the setup tutorial. But when I tried to connect module to my home wifi, it shows a troubleshoot message. I tried again many times. It didn’t work. Although, both blue and green lights are stable. Yet, the apps shows no device connected. I have been trying to do it since two days. But the same happens.
I have tried switching off the router then switching it on only when I reach the wifi/hotspot connection setup. But it didn’t work. I tried connecting it to hotspot but it didn’t work.
I have noticed that when the wifi/hotspot is off, the cloud light doesn’t get on. as soon as it is on, the green light starts glowing in an instant.
i think my wifi module gets connected to the wifi / hotspot but it is unable to respond to the app.
Also, I got the message to contact bolt customer service solution twice, saying Bolt app is not responding.
Please help.
I received the Bolt iot kit as a part of Iot training on Internshala. I have limited number of days to complete the training.

@vastartist15 try to reinstall the mobile app

I have done that several times now but it is not working

@vastartist15 as you have stated that the green light is on which means that there is internet connectivity between Bolt module and wifi. So can you verify that are you able to run small programs?

In your Bolt Cloud dashboard what is the status of your device? Do share that screenshot.

Hi @vastartist15,

Change the password of your wifi network/hotspot and then follow the setup process again. Also, check this video https://info.boltiot.com/how-to-setup-bolt

Do let me know in case you further assistance.


The Cloud dashboard as well as my app screen says no device connected

Hi @vastartist15,

What is the status of blue and green led after changing the password of your wifi network/hotspot ?

@vastartist15 do click on Add device and then follow the instructions

Yes. Done that! But didn’t work.

I changed my hotspot password, then the blue led was on but the green led went off. I tried to connect module to cloud and followed the tutorial, but when I reach the stage to connect it to my hotspot internet, the green led turns on but the app returns to the page listing available networks.

@rahul.singh1 @vishalvats2000
the problem has been solved now. The cloud dashboard and the app both now shows device and both LEDs are on. Thank you for your attention.

Hi @vastartist15,

It will be great if you can update here about "how did you resolve your issue? ". It will help others also.

The problem is solved. I changed the password then tried to connect wifi module to cloud via my home wifi. It got connected the second time.

1 Like