Bolt wouldn't turn on, blue led flickers

Done with the setup, updated it checked sample device control view all good. After few hours reconnected the module but it just does not turn on. The blue LED flickers on connecting and then goes off . Tried changing USB and power supply yet received same outcome. What should I do?

Are you sure that you used it correctly?? because if you short-circuit the bolt will not turn on. also did you feel that the module is heating up? if the module is heating up then it is short-circuited.

No there was no heating per se although it was connected straight for an hour. Also I used it as was instructed. And before the blue LED went off the green LED was gone even though Wifi was connected and device could be controlled. So if it is short-circuited I’ve to get a new module?

Is it possible to send a picture for a possible hardware issue?
If you’ve already used it, it is possible that it got short circuited. Did you try the set up all over again?
Sometimes it takes time for the module to get a stable connection, but in your case it is taking too long.
If you’ve already tried the above steps my suggestion is to replace the module.

change your wifi connection resource
and try to connect

There may be a possibility that you are connecting it some other Wifi source than the one you first connected with. Try with the same Wifi connection.

Other possibility is that your wifi is not stable. Than I suggest that connect your module with some other wifi right from the first step. If your device is not short circuited than it may fix your problem.

While working on controlling led project, My both bolt wifi module LED’s are flickering as you can see in the video attached. When I connect my bolt module to laptop using USB cable , then in first go both leds doesn’t get turned on. I need to press this part (image is attached)slightly or sometimes hold it on till the LEDs starts glowing.
Sometimes only blue wifi led blinks slowly. therefore I tried linking bolt module to the cloud and green led turn on and both led gets stable. (But my bolt module is already linked to my bolt cloud account and its status is offline. To make it online , I keep doing this.) What could be the possible reason behind this ?


What are the header wires in your Module connected with?

This is the whole hardware configuration I am working on (image is attached herewith). What could be the possible reason?


Most likely your USB port is loose. You can try powering your Bolt module by applying 5V power supply from the Arduino (if you have any). Or, you can make a request for the replacement of your module, if you got the module recently.

1 Like

I want to ask two things.
1). If my bolt module stop working in future then can I request for a new bolt module by paying the specified amount for it?
2). For how long can we request for the replacement of our bolt module?


Yes, you can order a new bolt module but less than the amount paid for the kit.

It comes with a one-year warranty so you can get a replacement in case of any manufacturing defect. We don’t do the replacement if there is any tampering on the module. Could include tampering with the headers, wifi module, etc.

okay, Thankyou so much.