Connection problem during wifi setup

I have connected the bolt wifi module to my laptop via USB . then i connected bolt hotspot with my ios device i turned ON my internet of ios device and the blue LED is blinking fast but during linking it to bolt cloud account,there is an pop-up that "You need to connected to the internet."And one more thing,during filling of ssid and password , which network i have to use , mine or some other wifi network?

Can you give me a screenshot?
You can try this
1st connect your phone to the hotspot by Bolt device.
After connection click the add device option and select the WiFi of your home, if it doesn’t work then connect it to any other phone’s hotspot.
It will be done.

Try connecting to WiFi router instead of mobile hotspot. Sometimes bolt module won’t connect to the mobile hotspot because it has frequency range of 5 GHz ,but bolt module is only operational at a frequency range of 2.4 GHz.

And yeah,give the ssid and password of your own WiFi which you have used to connect to the WiFi module.

hope this helps you

can i get ur number so that i can make sure with each step accurately…

access denied , when i reply with a screenshot…

Tell me the 1st problem you’re facing

You are doing it wrong!! First you have to add the bolt module to the cloud account you made using the bolt iot app.After then in the bolt iot app you will get an option to connect your bolt module to a wifi connection and make sure it has an internet connection.Even if you want to use a mobile hotspot rather than a typical wifi router then too it should not be of the same device on which you are pairing you bolt module to the bolt iot app.After you successfully enter the password of the wifi you choose in the Bolt iot app then your green light will switch on automatically.After than you can just open the Bolt cloud on you PC/laptop and then you will see the device added there.Then you can easily connect you Bolt module to your laptop anytime and then switch on the wifi/hotspot that you first connected you Bolt module to.

Ask again if you get any Doubts…

Hey there i was also getting such type of issue when i tried to setup bolt wifi module .
i solved this issue by uninstalling bolt app for phone and reinstall it , then after my wifi module works fine.
firstly you should try to connect hotspot of bolt wifi module more than 10 times .
if it not work then restart the whole module again and again for some time.
if your problem is not solve then do that step which i did at my time which i told you i first paragraph .
hope your problem will definetly solve by doing such steps.
have a good day .

I had the same problem while using ios app. I switched to the android app and tried adding the device again. It showed an alert “dont connect to wifi of 5 GHz and only to 2.4GHz”. My wifi was 2.4GHz and it didnt show up in the list. So i tried entering it manually(the network name and password", and voila it worked for me. The app is not the best.

You don’t need a wifi router nor secondary mobile to connect bolt to wifi network, you can connect your bolt module and any other devices using single mobile hotspot by following few steps:

  1. Sign in to bolt mobile app and after logging in through gmail turn OFF your mobile data and hotspot if any,then click on ADD DEVICES .
    2.Complete those 3 steps and select READY option,it will ask you to enable location, then u will get your Bolt device and the status will be showing as secured , then click CONTINUE .
    3.Then it will ask you to Add Network/setup VIA Hotspot , click on that option.
    4.U will be asked to enter SSID name and password, here you have to enter your mobile hotspot name and password and click the dialog box of " check if setting up via mobile hotspot".
    5.Click CONNECT option and then u will be asked to turn ON your hotspot, come back and again you will be asked to ON turn your mobile data.
    6.Then wait for your bolt module’s to show green led and with constant blue led light device ready to use.
    7.If there is some error popping up then go for troubleshoot and click skip option and continue with your project happily.
1 Like

How to changes the Frequency From 5ghz to 2.4ghertz

Hi @peru18ec092,

Refer this thread Change frequency from 5hz to 2.4hz

Go to your phone setting - Hotspot setting -> Setup hotspot -> Choose band 2.4 GHz

In Bolt IoT App, You can click on the “OK” button to dismiss the popup as it is just a warning. It is reminding you that the Bolt cannot connect to 5GHz WiFi networks and you should connect to 2.4GHz WiFi networks.

refer this way
step1 : please select your band wifi frequency as 2.4Ghz.

step:2:thereafter you doesn’t need data connection to be active while you are connecting to your bolt module,so please turn off your data connection.

step:3:then switch to your bolt device without switching any connection(like wifi/hotspot).

step:4:the application will automatically connect to the device either by wifi or it will provide its hotspot.

according to your query if you have any wifi device at home then connect to it or another way you should prefer using two smartphones.first one as hotspot site and other as to connect to bolt module,then connect second one with first with hotspot of second phone,then try to connect ur module via this would surely get success.

I tried many solutions online , but finally solved it by enabling the personal Hotspot option via the mobile data page.