Facing issue with voice input

Unable to recognize audio … i have used the ambient comand as well . To see that did my vm have the microphone access i ran the mic test and it was working properly

@f20212487 Can you please share a screenshot of your code as well? that will be helpful in resolving the issue.

Already uploaded
Processing: 1000012351.jpg…

Hi @f20212487

Please share a screen of your code, this will help us to to rectify the problem correctly

@f20212487 The screenshot posted above only contains the output.
In your subsequent reply, the code screenshot has not gotten uploaded. Can you upload again please.

Also, in your screenshot, the code is waiting for audio input. After you press ENTER and speak in the microphone, the prompt doesnt change from … to >>> ?

If it does then run r.recognize_google(audio) to check if the audio is getting recognized.

If the prompt doesn’t return then type Ctrl+c or control+c to get your prompt back.

Modify your code a shown below for adjusting ambient noise. Wait for 1 second adjust_for_ambient_noise function to work and then speak into the mic. Check if the prompt changes from … to >>>. Do remember to press ENTER after typing the below code so that the interpreter knows that you have completed typing the code.

>>>with mic as source:
...    r.adjust_for_ambient_noise(source)
...    audio = r.listen(source)

Do try out the above suggestions and let me know if your issue is resolved.

i tried ambient noise also it was not working
as I run the command python3 -m speech_recogniton the mic is working properly
but when I run the above commands the prompt stops … here and nothing gets stored in audio

@f20212487 Noted. We will try from our side to recreate the same and check if we are facing the issue and get back to you. Also we will check what could be possibly causing this issue.

In the meantime, is it possible for you to record a short 3-5 min video and share the google drive link where you are able to test the mic working properly with python command and the behaviour where the prompt stops regardless of your output. This might help us understand the issue better.

Also one more quick question, by any chance can you try this on any of your friend’s system who might be using Ubuntu?

Hi @f20212487

We tried the speech recognition on vagrant but we are getting issues( nit exactly the same issue you are facing) . It will take us some time to figure the issue and get the solution. Please be assured that we will get your issue resolved. In the meantime , you can try the previous solutions which we have shared. We will get back to you soon once we find the solution.

1 Like

Hi @f20212487

Apologies for the delayed response.

We tried the speech recognition project and were facing similar issues. This is possibly due to permissions not allowed in Ubuntu virtual box. We have executed the project on Windows from our side and verified that it is working as expected. We recommend you to run the project and install the required python libraries directly on Windows Operating system, so that you can proceed with the training and continue to learn.

If you still face any issues, please feel free to get back to us.