Project 6: Controlling device status and restarting device

I have been using Ubuntu 17.04 installed in VirtualBox to complete the tasks.
While doing this project, when I sometimes run device_status.py, it shows a message “An error has occurred”.
Also, when I run device_control.py, it restarts my Bolt, but after restarting, my Bolt doesn’t connect to the cloud. I have to setup the Bolt all over again, that too, with another phone.
This has happened every time I have restarted the module using device_control.py.

Can someone help me out?

Hey @utkarsh1499bansal
It would be good if you’ll provide your code also.

device_control.py

device_status.py

In device_control.py…This is the code to restart your device…if you execute or run this code ,your device will be restrated…and you have to setup the connection from the beginning…so this the code to only restart your
device…just setup the connection and move on to next part of the training…once you restart the device the device will forget the hotspot that you have connected already…see to it.

Ohh… I thought it was just like powering off and then powering on your Bolt module.

Thanks for the help.

Hi @utkarsh1499bansal,

What @viswamanii007 pointed out to you is wrong. The API call only restarts the device. It does not tell the device to disconnect from the WiFi. As such you should not need to setup the device again.

The issue is more likely something on your WiFi router side. Check how many other devices are connected to the WiFi router. Generally if there are too many devices connected to the WiFi router, the router does not allow certain devices to connect back.

But i have tried it many times, once i restart the device through API call,it automatically disconnects from my mobile hotspot and the blue led blinks slowly, it cannot connect automatically to my hotspot untill i repeat the connection setup once again.More over my device(bolt wifi module) is the only device that connects to my hotspot.After repeating the connection setup,my device connects to hotspot as normally before.i am just confused about it…whether the problem is in the device or my hotspot.so, i suggested to repeat the connection setup that solved the problem in my case.

Hi @viswamanii007,

Have you checked what firmware version your device is running on?

Please use the steps given in the following link to ensure that the firmware of your device is the latest available firmware.

Also, please check with other mobile hotspots if the Bolt WiFi module has the same behaviour with the others.

thank you…sir!! i will try it…

I have encountered the same problem