The analog A0 pin of Bolt IoT module is not working

The output at the A0 pin of Bolt IoT module always gives high. The visual output data always show 1.02 thousand or high. I have checked the circuit connections or codes for many times but the output is constant high. I tried with the LDR and LM35 sensor both gave the same output as 1.02 thousand(HIgh). I tried using a different USB cable or charger. The Bolt Module is powered on correctly and connect to the cloud.
This text will be hidden

Hi swapnilgavit19 I would like to solve the issue the pin is working fine because the temperature sensor is always reading the values 1.02 thousand because your place must be hot and 1.02 thousand is the maximum value that is obtained by the sensor try turning on the AC then the values will be automatically reduced.

it is the temperature sensor connected not ldr

Modify your code to read temperature sensor value. LM35 sensor gives you output in form of voltage. So if you have to read correct temperature then do the following steps (in python, you can convert into javascript)

  1. read the analog data and convert it into json
    data = json.loads(mybollt.analogRead(‘AO’))
  2. Convert data into int.
    sensor_value = int(data[‘value’]
  3. Read the temperature by converting voltage into temperature
    temperature = sensor_value/10.23

it looks like you are not varying the temperature or the light that is falling on the sensors
try to keep the device in different temperature and light conditions to change the output value
You are getting 1.02thousand volts for the light sensing project as the sensor is receiving the maximum light intensity it can read
try covering the sensor with your hand and then deploy configuration

hope this helps

One more thing to even if you keep your LM35 in freezer at -18 , the reading will not drop below 0.7 at max, this is due to limitation of bolt module,.
I took the maximum reading to 60 degrees by keeping it near to gas burner (Although sensor supports 150degree but I was more worried of my wires getting burned)

1 Like

Its just a connection problem. i also faced the same problem.
Check the connections:

VCC -> 5V
OUT -> A0